Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > More steering issues

Join Wrangler Forum Today


Thread: More steering issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-11-2007 07:56 PM
upinar the pulling to the left under acceleration and pulling right when you brake is torque steer. I had it pretty bad and i took a look under and the left upper control arm mount of the frame was ripped off. Check all your mounts on the axle and frame for flexing and check your arms bushings.
11-11-2007 07:49 PM
06R1Raven01TJ How do I put pics on this forum?
11-10-2007 09:44 PM
mr4x4 were's the pics I didnt see any pics
11-10-2007 09:34 PM
06R1Raven01TJ Actually on the way into work, it floats its not sluggish just over sensitive. Definetly pulls to the left on acceleration and dips way to the right when you let off the gas not when braking like I originally stated. I let the wheel go centered. Hit the gas, straight to left, off the gas, straight to the right. The lift does have control arm but no adjustability. Did the pictures I put up work and if not how do I post them? Any small movement in the cab relates to a steering imput through me. I drive with one hand centered on the wheel and the other on the stick, small bumps move my hand ever so slightly resulting in a imput, a prob I never had on my 97. What should I try first? Replace the stabilizer? Ive tried to get any movement in the steering componets by moving them back and forth while the vehicle was on the ground, everything feels solid.
11-10-2007 05:44 PM
activelydying
Quote:
Originally Posted by Simple Scout View Post
It sounds to me like you have multiple problems with your steering and maybe even some suspension problems. Have you had an alignment done? I'm not talking about a quickie alignment, I'm talking about a 4 wheel alignment from a qualified 4wd shop.

Driving in mud? New one on me. Are you saying it feels sluggish when you're turning the wheel?

Drop pitman arm? Can you tell if they used a drop bracket when the trac bar was installed?

Pulls to the left when you accellerate? Do you know if the lift they installed came with replacement control arms? If so, are they adjustable?

Sensitive steering: You have too much toe-in. That makes your steering feel "twitchy" and too much toe-out will make your steering feel sluggish.

Dealerships suck when it comes to aftermarket parts. Most only care about making it look good from the curb. They don't care how it performs. That's why I think you need to find a good 4wd shop there in LV. We have some LV members that will hopefully chime in and give you some recomendations.
HOLY CRAP!!!! Scout, you do know stuff.
11-10-2007 04:25 PM
06R1Raven01TJ Ok got some pics of the set up, I'll try to figure out how to post them. The dealer said it went to the allignment shop before I picked it up but thats like saying OJ is innocent of everything, Seriously doubt it. I'll go do some more diagnostics and get back on the forum later.
11-10-2007 01:42 PM
Rockodile I'd start by checking the ball joints the rod ends and the TB bushing and whatever joint it has on the opposite end. If you can get any movement out of the rod ends they need to be replaced. If when jacked up you can move the wheel (holding at top and bottom) you could have bad unit bearings. If when lifting up under the raised tire with a prybar or pipe there is movement at the ball joints that could be part of it as well. Also while on the ground try and shake the drag link and tie rod as well as the track bar. Any movement in any of these components can add up to poor steering.
11-10-2007 12:23 AM
mr4x4
Quote:
Originally Posted by Simple Scout View Post
That's why I think you need to find a good 4wd shop there in LV. We have some LV members that will hopefully chime in and give you some recomendations.
ted weins 4x4 in down town las vegas 702-735-5656
they will treat you right plus some of themare part of
http://www.vv4w.org/index2.asp
and
http://www.totalkarnage.net/totalkarnageLV.htm

http://sincity4x4.org/
http://www.nevadabackroaders.com/
those are some of the local sites
11-09-2007 11:17 PM
Scout It sounds to me like you have multiple problems with your steering and maybe even some suspension problems. Have you had an alignment done? I'm not talking about a quickie alignment, I'm talking about a 4 wheel alignment from a qualified 4wd shop.

Driving in mud? New one on me. Are you saying it feels sluggish when you're turning the wheel?

Drop pitman arm? Can you tell if they used a drop bracket when the trac bar was installed?

Pulls to the left when you accellerate? Do you know if the lift they installed came with replacement control arms? If so, are they adjustable?

Sensitive steering: You have too much toe-in. That makes your steering feel "twitchy" and too much toe-out will make your steering feel sluggish.

Dealerships suck when it comes to aftermarket parts. Most only care about making it look good from the curb. They don't care how it performs. That's why I think you need to find a good 4wd shop there in LV. We have some LV members that will hopefully chime in and give you some recomendations.
11-09-2007 11:08 PM
06R1Raven01TJ
More steering issues

First off hi and thanks for any help, just joined the forum today so Ill get more information on my rig as soon as possible. I have a 01 4.0L sport, I just bought it from California because I blew the engine in my 97TJ. This Jeep has a 4 inch pro comp short arm kit adj trac bar, Bilstien 5100 shocks and Huge pro comp steering stabilizer about the same size as a normal shock. I can t even explain how bad the steering is on this Jeep. It constantly feels like you are driving in mud. It looks like a 4 inch drop pittman arm. When you excellerate it pulls to the left and when you brake it pulls to the right I fly helicopters and it feels like it needs anti torque pedals! It is so bad that it actually feels unsafe at anything past 65. The steering is so senitive at speed it only requires muscles in your fingers to drive. when you let go of the steering wheel it drives straight. When you shift gears you have to anticipate and steer slightly to the left so it doesn't hit the bumps in the next lane. The dealership I bought it from oviously thought something was wrong cause the replaced the steering box and lubed the crap out of everything that had a zerk fitting. I havent pulled the stabilizer yet and I'll post a pic when i get a chance any help would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC