Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > A/C pressure and quantity

Join Wrangler Forum Today


Thread: A/C pressure and quantity Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-25-2011 08:38 AM
jfbilbro If the expansion valve is bad it can cause both the high and low pressures to be to low. That will be the case if it's stuck closed or partially closed....they're only 25.00...
09-25-2011 08:36 AM
jfbilbro or the expansion valve could be bad....it can cause low hi&low side pressures.......
09-25-2011 01:06 AM
jcbrindle I did some more research and found that that valve is just there as part of the install process and is not needed. The o-ring was torn. I removed it and charged it with 2.75 LBS and it blows 45 degree air. The pressures are still low at 12 low side and 165 high side. I think the compressor is just getting weak.
09-24-2011 10:04 PM
jcbrindle Awsome, I will try it. Thanks
09-24-2011 07:50 PM
jfbilbro forgot to add that my high side is 235 psi and lo side is 38 psi....i'm getting 39 degree air from the vents when ambient air is 90 degrees
09-24-2011 07:34 PM
jfbilbro I was having that problem...not cold enough....turns out there's a 2 piece one way valve in the end of the hose that attaches to the back side (evap. side) of the accumulator/drier...one part of that little tiny sucker was sticking....took it out and used very fine emory paper on it and the tube it rides in, swabbed it with refrigerant oil and now i'm blowing snow balls.....careful not to damage the o-rings on the 2 pieces and above all remember which way they come out.....BTW, mines a 91 too.....
and mine took exactly 2.75 lbs. plus a 2 oz. oil charge....
BTW, i put 134 in mine and no problems to date....just had to buy the kit that screws onto the inlet connectors to accept the 134 filler hose.....
09-24-2011 05:26 PM
jcbrindle
A/C pressure and quantity

Hey guys, this is my first post . I just bought a 1991 Wrangler this week and it came with factory A/C. It works and blows kinda cold but not where I think it should be. The sticker is missing from under the hood with the quantity of R12 to charge the system with. I have searched everywhere and have found numbers from 2.38 to 3 LBS. Any body have a the same set up with a 2.5L engine that could tell me the charge spec? I evacuated the system last night and pulled 1.25LBS out and recharged it with 2.25 based on what I have found so far but I'm still uncertain thats correct. 2.25 LBS gives me about 170 psi high side at about 75 degrees last night so I think I'm close. My other problem is that the low side is only 10 psi no mater have much I add or subtract, I tried 1.25 lbs up to 3 lbs and suction stays at 10 psi. bringing the engine above idle brings the suction psi down to about 5 psi. I'm a mechanic but a aircraft mechanic so my troubleshooting skills with freon is very limited. I just know enought to service the system and know when somthing just isnt right. Any help would really be a appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:45 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC