Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > my jeep is having troubles starting

Join Wrangler Forum Today


Thread: my jeep is having troubles starting Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-10-2011 10:56 PM
suggerdaddy Thanks for the help turns out it was a bad check valve in the fuel pump
09-26-2011 07:53 AM
bllshybl i have the same no start issue, crank and crank no start, but crank once turn off the key and crank again fires right up..same problem with my 91 mustang,,i dont know the solution
09-25-2011 09:58 PM
suggerdaddy the strange thing is when i press my clutch pedel down harder than normal it starts fine
09-25-2011 09:29 PM
yoopone Lot's of threads covering this subject out on the forum, start with replacing the fuel pressure regulator. It is located on top of the fuel pump. You will need to drop the fuel tank unless you have a body lift.
09-25-2011 05:25 PM
suggerdaddy I have replaced my spark plugs. When I go to start it for the first time it just cranks over I try it again and it starts fine.
09-25-2011 03:29 PM
jameslee97206 Fuel preesure regulator?
09-25-2011 03:28 PM
Irongrave before you start it do you hear the fuel pump kick on. sounds like it might be losing prime in the fuel rails. next time when you go to start it turn the key to ON for about 15 secs then start it and see what it dose. (my old XJ would do that a lot just learned to re prime the system to get it fired
09-25-2011 03:25 PM
Velislide Plugs? Weak spark? Plug wires?
09-24-2011 07:43 PM
suggerdaddy
my jeep is having troubles starting

I had been having troubles starting my jeep I would go to start it and it would crank over 30-40 seconds before it would start. Someone told me to check the crank sensor so I replaced it and it still has the same problem. Where can I go from here? ?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC