Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Pressure gauge

Join Wrangler Forum Today


Thread: Pressure gauge Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-24-2007 11:05 PM
CaptZZ Thanks for the help, still having the issue so I'll look at that.
11-21-2007 02:39 AM
AzTJ Its a fairly common thing. Most of the time its the sending unit itself as these motors run a higher pressure than most others. Check the sending unit and make sure that all connections are tight and that its screwed in all the way. If so and the problem persists, replace it. It's a $7 part.
11-21-2007 12:01 AM
CaptZZ
Pressure gauge

I recently bought an '04 X and sometimes when I fire it up the oil pressure gauge doesn't budge. It'll take three or four starts before it'll finally pop(and the annoying check gauges alarm goes off) and all is well. As this only happens once every two weeks or so I'm confindent there is no issue with the oil pump itself, but sure if I should start dinking the pressure sending unit or start by replacing gauge. Anyone else run across this problem?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC