Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Bestop Supertop Question/Problem..

Join Wrangler Forum Today


Thread: Bestop Supertop Question/Problem.. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-12-2006 06:58 PM
1BLKJP I'm thinking now that what you got might be the header for an 03 or newer.

Glad to hear they took care of you.
07-12-2006 03:25 PM
bluvikng Wow........glad you got that figured out. Having that problem just didn't sound right. Kudo's to Bestop for sending you the correct header for free. That is great customer relations right there.
07-12-2006 01:29 PM
PKO Problem fixed, the new windshield retainer assembly and brackets arrived from Bestop today. The old brackets, and the brackets they sent today were TOTALLY different. I could tell as I tightened it down the thing was going to be fine, hugs the windshield molding snuggly and fits great, no room for air to get underneath and lift it now. Thanks for the help, now I've got a starting related question coming up next, lol.
07-11-2006 12:12 AM
PKO I have called Bestop and they are sending me a whole new windshield retainer piece with brackets for free. I will let you guys know how it turns out. I had to drive a 3 hour drive the other day and before leaving I installed it once again. I was going about 65mph for about 5 miles and then kicked it up to around 70mph and it lifted on me once again so I'm pretty fed up with it, hopefully the new brackets and windshield retainer piece will do the trick. I will post results.
07-10-2006 08:12 PM
amerijeep I was interested if PKO had any updates on this.
07-10-2006 07:06 AM
sound hound My bikini (Bestop) uses the same windsheild bracket and it fits-works flawlessly. Try re attaching as 1BLKJP recommends, and if it fails, your brackets (or channel) could be "tweeked". If it comes to that you could possibly talk to Bestop and see if you can get replacements.
07-06-2006 09:31 PM
PKO Hey thanks for the tips. Something I notice is that as I tighten the bolts down the whole piece gradually inclines bacwards and naturally wants to separate from the windshield molding, it's like it doesn't want to stay flat, it must be a freak deal because Bestop claims they haven't had the problem before.
07-06-2006 07:43 PM
1BLKJP That's a bummer man. When you are putting the header on top of the windshield try doing it with the bracket pieces completely removed from their mount. Then when you have it where you want it (which is going to be as far forward as it will sit) then put them on with the bolts and tighten it down with the half inch socket (I believe). Make sure you tighten it down fairly good. That way it shouldn't be able to roll back on you like that.
07-06-2006 01:43 AM
PKO
Bestop Supertop Question/Problem..

98 Wrangler original Hard Top. I bought a Bestop Supertop from a member on E-Bay. Everything installs great, I get up over 60mph and the windshield retainer flips up about 1/2 an inch on the corners, the whole windshield retainer is angled backwards. I reinstall putting pressure on the front of the retainer as I tighten up the 2 bolts, drive around town I'm fine, get on the highway over 60mph again and it flips up on me. Here are some pictures, I'm at a loss and I really don't want to feel like I wasted over $500 on this thing, I like the soft top but it's no fun having rain/air coming through the front corners of this top. Hopefully the following pictures will help someone help me with this.

Here it is installed before the problem has occurred...

On the inside before the problem...

And now after the windshield retainer has caught 60mph wind..


Notice here how the retainer is angled backwards after popping up...

And some misc. pictures....



Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:27 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC