Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Tennessee Jeep Forum > Heater only blowing in cold

Join Wrangler Forum Today


Thread: Heater only blowing in cold Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-12-2012 01:00 PM
Departee98 Well it worked for a while, now it is only blowing in cold but at full speed.
10-25-2011 03:34 AM
225grasshopper You may have had a air pocket and it worked its way out
10-18-2011 08:16 PM
Departee98
Quote:
Originally Posted by aelwero View Post
pfm
pfm?
10-18-2011 07:08 PM
aelwero
Quote:
Originally Posted by departee98
for some reason it is working now. I didn't touch the heater in any way besides turning it on
pfm
10-17-2011 05:03 PM
Departee98 For some reason it is working now. I didn't touch the heater in any way besides turning it on
10-11-2011 10:27 PM
06blackmax ^^^^ What he said.
10-11-2011 06:21 PM
aelwero any parts store should have it or be able to order it... usually around $40-50
10-11-2011 05:57 PM
Departee98
Quote:
Originally Posted by 06blackmax View Post
Sounds as if the motor is going bad. When it heats up from temp and from usage it'll do that.
Where could i find a motor and for how much?
10-08-2011 09:20 PM
06blackmax Sounds as if the motor is going bad. When it heats up from temp and from usage it'll do that.
10-08-2011 09:05 PM
Departee98
Quote:
Originally Posted by 06blackmax View Post
The blower speed not being fast enough could be the blower motor resistor, but normaly when it goes out you only have high nothing else. If your temp does not warm up you prolly have a bad thermostat(stuck open). Maybe this will help get you in the right direction.
It's blowing hot but not powerfully, and as it warms up from cold to hot the blower actually slows down.
10-08-2011 05:36 PM
06blackmax
Quote:
Originally Posted by Departee98 View Post
It was the radiator which was fixed, then it slowed down to about half speed but is now blowing hot again, same thing or try something else?
The blower speed not being fast enough could be the blower motor resistor, but normaly when it goes out you only have high nothing else. If your temp does not warm up you prolly have a bad thermostat(stuck open). Maybe this will help get you in the right direction.
10-07-2011 02:51 PM
Departee98 It was the radiator which was fixed, then it slowed down to about half speed but is now blowing hot again, same thing or try something else?
10-06-2011 10:41 PM
06blackmax Is the cable broken going to the flap door under the dash on the passenger side?
10-04-2011 12:56 PM
Departee98
Heater only blowing in cold

As the title says my heater is only blowing cold air, I've tried the fuses, put coolant in the radiator and its still not warming up. Any one with more knowledge about how to fix this issue please post your solution.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC