Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > Sway bar disconnect kit question

Join Wrangler Forum Today


Thread: Sway bar disconnect kit question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-15-2011 06:53 PM
InvertChaos
Quote:
Originally Posted by tyle1720

Did you need to put longer brake lines on or are yours ok?
Not with 2.5" of lift. You'll probably have to with more though.
10-15-2011 06:11 PM
tyle1720
Quote:
Originally Posted by InvertChaos

Do the other one too and try again. Nope the rear sway bar doesn't actually limit flex like the front ones. In fact you have a higher change of roll over with the rears disconnected.
Did you need to put longer brake lines on or are yours ok?
10-15-2011 05:52 PM
InvertChaos
Quote:
Originally Posted by tyle1720
Yeah I only unhooked the one link but I defiantly did not have movement like that. And is your back sway bar off too?

Weird...
Do the other one too and try again. Nope the rear sway bar doesn't actually limit flex like the front ones. In fact you have a higher change of roll over with the rears disconnected.
10-15-2011 05:51 PM
tyle1720 Yeah I only unhooked the one link but I defiantly did not have movement like that. And is your back sway bar off too?

Weird...
10-15-2011 04:47 PM
InvertChaos So you disconnected and drove up in a rock or something? I only have a 2.5" suspension lift and 1.25" body lift and have great articulation.

10-15-2011 04:43 PM
tyle1720
Sway bar disconnect kit question

Hi everyone, I've got some rocky trails out back and I am interested in getting a "quick" sway bar disconnect kit. My question is how do the extreme jeepers get so much articulation in there front axle?? I unhooked the sway bar today and went riding I noticed only a bit of movement on the front axle. How can i get more? Ive got 33s with a 4" lift. Also if I put this kit will I need to buy anything else.. Ex longer brake hoses? Haha

Any input would help

Cheers

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:21 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC