Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Help with Heater problem

Join Wrangler Forum Today


Thread: Help with Heater problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-10-2008 09:43 PM
silentthinking I might have a similiar problem (I think)...

My air is stuck on Defrost only. Both cold and hot air works and variable fan speeds work as well but I can not get the air to blow out of the front vents.

Please advise if I have the same problem? Thanks a lot in advance!

Also, sorry, but I am not mechanical. If my problem is the same as this one, could instructions on how to do these task be posted here or emailed to me? I am not afraid to try and adjust/fix it myself. I don't think $1,000.00 + to take off the dashboard that the dealer suggest as a first option is what I would like to do.

A friend suggested a clothes hanger solution was on the internet because some "flapper" was stuck...not finding that solution viable.


Previous entries:
richp wrote:
Two causes, vacum and the cable behind the contols, pretty easy to fix. On the 97 and 98 it maybe a small $15 dollar pin that entails an $800 labor charge, the pin is in the heater box so it's the same as replacing the heater core or the evaporator. I don't think the pin holds true for the newer one, they supposedly fixed it with a steel pin vs the plastic one in the older models but I could be wrong..

BPD11 wrote:
i fixed it, it was the vac line on the drivers side of the motor. its popped off. took me 30 seconds to fix

RSVP,

silentthinking10
12-04-2007 11:09 PM
BPD119 i fixed it, it was the vac line on the drivers side of the motor. its popped off. took me 30 seconds to fix
12-04-2007 05:22 PM
richp Two causes, vacum and the cable behind the contols, pretty easy to fix. On the 97 and 98 it maybe a small $15 dollar pin that entails an $800 labor charge, the pin is in the heater box so it's the same as replacing the heater core or the evaporator. I don't think the pin holds true for the newer one, they supposedly fixed it with a steel pin vs the plastic one in the older models but I could be wrong..
12-04-2007 04:13 PM
machine same problem on my 98
12-03-2007 11:14 PM
BPD119
Help with Heater problem

2005 TJ the heater is stuck on defrost. it will shut off and the blower will change speeds, but it will not change positions from vent to defrost to feet, etc. is this a common fix? or something it has to go to the dealer for. im still under warranty but if its something i can do myself to save a trip i would like to
thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC