Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Guages, Interior Lights, Radio stopped working

Join Wrangler Forum Today


Thread: Guages, Interior Lights, Radio stopped working Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-21-2011 06:26 AM
BigSahara :::Found the issue:::

It was the IOD fuse under the hood. I'm not sure what this is for but apparently replacing it made everything work again. Does anyone know what it does? Now the only problem is the amp to my sub-woofer is not working so I'm assuming there's still a ground out somewhere.
10-20-2011 10:51 PM
wranglerTX check your fuse box, happen to me like 3 weeks ago and found a bad fuse. dont remember wich one.
10-20-2011 09:19 AM
BigSahara I just found this:

I have a 2000 TJ wrangler I went out today and everything ... - JustAnswer
10-19-2011 07:33 PM
oilwell1415
Quote:
Originally Posted by fabrikate_it View Post
check all the grounds you can find and use a test light on all the fuses to be double sure they are good to go sometimes a visual check will fool you.
+1. A visual check doesn't always tell the whole story. If you're not getting power to the fuse it doesn't matter if it's good or not. Using a test light to check them will show that problem if it's there. Ignition switches are famous for this sort of problem on some models. I don't know if the TJ is one of them, but if you're not getting power to the fuse that's where I would start the search. It sounds like the accesory terminal of the switch hasn't been working right for a while and now it's finally failed completely.
10-19-2011 06:14 PM
fabrikate_it check all the grounds you can find and use a test light on all the fuses to be double sure they are good to go sometimes a visual check will fool you.
10-19-2011 05:47 PM
BigSahara
Guages, Interior Lights, Radio stopped working

I just recently hit a pretty bad bump in the road in a construction area that I drive through daily and suddenly my radio and the aftermarket amp, gauges, interior lights and even the OBDII port are not working. I checked the fuses and everything looks fine. The battery seems fine as well, both terminals are tight. This used to happen a lot but when I hit the same bump, the radio shut off, then it would come back on in a few seconds. This time is permanent. I even took the entire dash apart and the connectors for the gauges look perfect. I know it's probably a loose ground somewhere but I'm not sure where to look. The Haynes manual doesn't say jack about this. Should I just take it to the stealership?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC