Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > new brake system. and now no brakes

Join Wrangler Forum Today


Thread: new brake system. and now no brakes Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-04-2011 07:52 AM
sevenservices nice find guys. glad to hear your back on the right path!
11-04-2011 01:54 AM
Payyourtoll Same thing happened to us. Damn things were upside down.
11-03-2011 04:50 PM
stykthyn
Quote:
Originally Posted by frankenjeepster View Post
GaryK. and everyone else. who wouldve thought that the brake calipers would fit on either side. I checked first thing this morning and sure enough. they were on wrong. changed em around and what a u know I have instant brakes. gotta still bleed em but the pedals high and strong. so thanks everyone for your inputs and remember there's no such thing as a dumb question. you guys rock and if u ever get to abilene Texas I would be glad to buy u guys a beer. thanks again.
thats good to know info right there. I never would have suspected that.
11-02-2011 10:05 PM
DirtyRob I have just replaced 2 bad brake lines and master cyl on my sons Jeep. I was in a rage after the second evening of bleeding and pumping the pedal. I have done a lot of brakes in the past, but that whole ordeal was a real pain. I finally got some new speed bleeders and a vacuum pump and started with the passenger rear and it worked perfect. Now he stops much more better gooder
11-02-2011 11:44 AM
frankenjeepster GaryK. and everyone else. who wouldve thought that the brake calipers would fit on either side. I checked first thing this morning and sure enough. they were on wrong. changed em around and what a u know I have instant brakes. gotta still bleed em but the pedals high and strong. so thanks everyone for your inputs and remember there's no such thing as a dumb question. you guys rock and if u ever get to abilene Texas I would be glad to buy u guys a beer. thanks again.
11-01-2011 01:06 PM
Nubby55 Did you bench bleed the MC before you put it on?
11-01-2011 12:53 PM
Garyk May be a dumb question but did you put the calipers on the right wheels? If not the bleeders will be down instead of up.
11-01-2011 11:13 AM
frankenjeepster follow up. I shoulda bought more brake fluid and gonna have to try again tomorrow. have to get back to work. however. I did as y'all said. let the fluid run thru so there's positive fluid and no air. pedals getting better so thats a plus. but still have air locked in their somewhere. gonna try it again tomorrow appreciate all the help
10-31-2011 03:23 PM
stykthyn
Quote:
Originally Posted by sevenservices View Post
Before you start bleeding again you may want to remove the lid on the MS, crack the bleeder open and let it run. (but not empty) out each line to be sure all lines are full without any air at all. Fill the MS over and over so it never runs dry.

be sure you start at the right rear tire, left rear then right front and left front. If you bleed in a different order you can end up with an air pocket that moves back and forth wheel to wheel and never goes away.
A mechanic neighbor showed me this years ago. been invaluable.
10-31-2011 02:50 PM
sevenservices cool, let us know how it goes. I've gotten pretty frustrated at bleeding before when air gets trapped.
10-31-2011 01:52 PM
frankenjeepster alright appreciate the info. will let u know how it goes. thanks
10-31-2011 01:49 PM
sevenservices i know you don't want to hear this... but with all new stuff you might still have air in there somewhere. It takes a LOT of fluid pushing through to get it all out. Make sure you do not run the MS dry either, I've seen a little air get sucked down into the MS and into the tops of the lines at the front. It took close to a hole cup or more of fluid pushing through the lines before all the air was out.

Before you start bleeding again you may want to remove the lid on the MS, crack the bleeder open and let it run. (but not empty) out each line to be sure all lines are full without any air at all. Fill the MS over and over so it never runs dry.

be sure you start at the right rear tire, left rear then right front and left front. If you bleed in a different order you can end up with an air pocket that moves back and forth wheel to wheel and never goes away.
10-31-2011 01:10 PM
frankenjeepster yes everything is oem parts
10-31-2011 12:51 PM
stykthyn Stock parts?
10-31-2011 12:44 PM
stykthyn Stock parts?
10-31-2011 12:33 PM
frankenjeepster it will pump up a little but not like it should
10-31-2011 12:30 PM
stykthyn Can you pump the pedal and buil pressure?
10-31-2011 12:19 PM
frankenjeepster I've looked and haven't found any. I'm at a loss
10-31-2011 12:12 PM
stykthyn Leak somewhere?
10-31-2011 11:47 AM
frankenjeepster thats what i thought i thought i could have gotten a bad one so i took it back and replaced it the second time.. didnt think i could get two bad ones
10-31-2011 11:43 AM
stykthyn Sounds like you have a bad MC.
10-31-2011 11:41 AM
frankenjeepster
new brake system. and now no brakes

I have a 1990 YJ. I had to replace the entire brake system. master cylinder, booster, shoes, pads, wheel cylinders, rear brake lines, calipers after i upgraded the axles to Dana 44s. I've built the jeep from the ground up and I am at a loss on the brake system. I have bled the brakes multiple times bench bled the master cylinder and still the pedal continues to go to the floor. I am running a chevy 350 and was thinking it might be pulling to much off the booster but even when I disconnect the vacuum line the pedals hard buts still no brakes. I've adjusted rear drums and they are perfect b I'm just confused bang help would be huge

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC