Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > 2 possible problems...Looking for advice

Join Wrangler Forum Today


Thread: 2 possible problems...Looking for advice Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-01-2011 04:24 PM
Tonycrd Second that. Look in the radiator. Put the overflow bottle level at full.
11-01-2011 03:45 PM
Skyhawk32 Check the antifreeze level and keep an eye on it. Every time I smell antifreeze in any vehicle it has been a heater core.
11-01-2011 03:39 PM
M109Pilot
2 possible problems...Looking for advice

I have owned my TJ for just about a month now and I have two things that are bothering me. I have known that my heat doesnt get very hot at all. At most it gets warm. Today the outside temp was around 50 degrees and my heat would only blow out at about 80 which to me felt luke warm. I also notice a slight smell of what might be antifreeze when I have my dash vents on. Is it possible that my heater core is leaking? I don't notice anything leaking on the floor and nothing under the jeep.
My 2nd thing is that I noticed that my radiator hose coming from the radiator going to what I believe is the T-stat (pardone my lack of knowledge) doesnt feel like it has anything flowing through it. My jeep is a 99 with a 2.5Land doesnt overheat and the temp stays under 210 all the time, whether I am sitting in traffic or cruising at 55, it doesnt get hot. I have been driving this jeep all over town even when the outside temp was 80 it doesnt overheat. Anyone see any potential issues with this?

Jason

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC