Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > PCV valve

Join Wrangler Forum Today


Thread: PCV valve Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-13-2011 08:36 PM
aford89 we replaced everything except the block itself, used the old head but had it dipped and milled and everything that attatches to it is brand new
11-12-2011 11:37 AM
Nubby55 I have an 90 4.2 mine does the same thing your is doing, plus it will blow oil out the dipstick under heavy load or high RPMs, like 65 MPH.
I have low compression, bad rings from PO running it hot!

I don't know what you mean by rebuilt eng. new rings and all.
It is impossible to "rebuild an eng." with out new rings. REBUILDING an engine is to renew all the surfaces and replace all the rings, bearings gaskets, seals, freeze plugs, cam or regrind the cam, every thing in the engine. If someone just put a new set of rings and bearing in an old engine that' not a rebuild, it's a ring job, and you can still have blow by if the cylinders are worn.
Have compression check done to see what you are working with. Good Luck!
11-12-2011 08:56 AM
kik
Quote:
Originally Posted by jk'n View Post
Here is the post that I was referring to:
If I'm off base correct me, but isn't that for a FI engine. I agree with cleaning all of the hose conections and I would even throw on a new PCV because they're cheap, but the rear breather on my 89 4.2 (carb) vents directly into the air cleaner. The only fresh air comes through the air cleaner itself. That's why I mentioned that if oil is pushing through under load (increased oil pressure) the engine might have one or more clogged returns.
11-12-2011 04:54 AM
90YJinPC had the same problem myself, it was just like jk'n said, the line between the pcv and carb was clogged @ the inline orifice.
11-11-2011 11:23 PM
aford89 Thanks i have the 4.2 so im finding very different pictures and routes is the PCV valve line supposed to tie into the front at the base of the carb? Its the stock carb that came with the 4.2
11-11-2011 10:44 PM
jk'n Here is the definitive information on the CCV system for the 2.5 and the 4.0:

Attachment 77162
11-11-2011 10:18 PM
aford89 Thanks i will have to look tomorrow and see if thats it, so the front plug hose goes to the manifold and not the bottom of the carb?
11-11-2011 09:54 PM
jk'n
Quote:
Originally Posted by aford89 View Post
i tried searching posts and all i found was bad PCV valves and i know mines good....
Here is the post that I was referring to:

Quote:
Originally Posted by onroad View Post
The crankcase ventilation on these use a metered orifice, the threaded fitting on the intake manifold. The hose on the valve cover to that fitting pulls vacuum, and gases from the crankcase back into the intake manifold.

The other hose, from the valve cover to the airbox, draws fresh air INTO the crankcase. Completing the system.

The fitting on the manifold has a small machined hole which limits the amount of vacuum it pulls on the crankcase. That commonly gets clogged. When that happens, the blowby gases, carrying oil particles, are pushed out the wrong way, back into your airbox.

I'd pull the fitting and see if it's clogged.
11-11-2011 08:53 PM
aford89 i tried searching posts and all i found was bad PCV valves and i know mines good....
11-11-2011 08:35 PM
jk'n There is a post on here about this. It has to do with a small orifice and I'm thinking it is right in the elbow where it attaches to the valve cover or where it attaches to the intake manifold that gets clogged. pull it, clean it and put it back together. Problem should be gone.
11-11-2011 08:11 PM
aford89 it blows oil out of the rear "breather" only when under a load the other times its just the gases, they are new hoses all the way around, and we cleaned the valve cover before we put it all back together, dont know where else it would be clogged....
11-11-2011 07:24 PM
kik On the 4.2 you have one PCV at the front of the valve cover as you know and good that it's working. The breather at the rear just vents into the air cleaner through an "element" within a plastic housing that's clipped to the air cleaner. I'm not sure that I understand your question, but if you don't have one they're available. Or, you can disconnect it and let it vent outside of the air cleaner, pre 1968 vehicles. If you're saying that your 4.2 is blowing a lot of oil through it into the air cleaner then you have an internal engine problem, probably clogged ports.
11-11-2011 06:22 PM
aford89
PCV valve

What is everyone doing with their PCV valve that goes into the breather? on a 4.2. We have one that the valve is working fine but under a load the breather will get full of oil coming out of the exiting hose. The motor just got rebuilt (new rings and all)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:11 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC