Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Windshield lights....few basic questions.

Join Wrangler Forum Today


Thread: Windshield lights....few basic questions. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-17-2011 09:46 AM
Hilldweller
Quote:
Originally Posted by scottbabu View Post
I just installed PIAA's this weekend. Everything went fine until I had to connect the wire from the switch to an existing "hot" wire. I tapped into a brown wire and while the little led on the switch lights up and goes from red to green ... the lights themselves do not light up.
I have triple checked and everything in connected. Are there wires you tap into that don't have enough "juice" to power the lights?
(Don't mean to highjack your thread ...).
11-16-2011 12:14 PM
Daniel_M My Rigid Dually's. Barely noticable

-Dan
11-15-2011 08:31 PM
jkjeeper06
Quote:
Originally Posted by scottbabu
I liked the simplicity of hooking the white straight to the battery liked mentioned above. This is the battery drain from the led light on the switch that I'm concerned about.
I don't think the LED is on unless the lights are and if those are on then your battery will definitely die. If you want the ease of hooking straight to the battery with no relays you can buy the KC Hilites wiring kit. I think I paid $18 for mine on quadratec
11-15-2011 05:05 PM
scottbabu I liked the simplicity of hooking the white straight to the battery liked mentioned above. This is the battery drain from the led light on the switch that I'm concerned about.
11-15-2011 03:56 PM
jkjeeper06
Quote:
Originally Posted by scottbabu
PIAA 510. I like the 4" size versus the latger 6" most seem to do.

If I connect straight to the battery, there is a small LED light on the switch they provide. Dumb electrical question ... is there enough draw from this LED light to drain the battery? Am I better off putting in my own switch with no LED indicator light?
I have the 510's on my jeep now and i love the lights. I didn't use the switcher came with because when I looked at the instructions it said you need a relay. But to answer your question no it won't drain your battery if it is hooked up according to directions
11-15-2011 03:09 PM
scottbabu PIAA 510. I like the 4" size versus the latger 6" most seem to do.

If I connect straight to the battery, there is a small LED light on the switch they provide. Dumb electrical question ... is there enough draw from this LED light to drain the battery? Am I better off putting in my own switch with no LED indicator light?
11-14-2011 04:47 PM
ironhead79
Quote:
Originally Posted by scottbabu
I just installed PIAA's this weekend. Everything went fine until I had to connect the wire from the switch to an existing "hot" wire. I tapped into a brown wire and while the little led on the switch lights up and goes from red to green ... the lights themselves do not light up.
I have triple checked and everything in connected. Are there wires you tap into that don't have enough "juice" to power the lights?
(Don't mean to highjack your thread ...).
Which PIAAs?
11-14-2011 04:09 PM
RB-10rubicon
Quote:
Originally Posted by scottbabu
I just installed PIAA's this weekend. Everything went fine until I had to connect the wire from the switch to an existing "hot" wire. I tapped into a brown wire and while the little led on the switch lights up and goes from red to green ... the lights themselves do not light up.
I have triple checked and everything in connected. Are there wires you tap into that don't have enough "juice" to power the lights?
(Don't mean to highjack your thread ...).
Go strait to battery with both white wires i have the same lights .and im sure you wont forget to turn them off when you park
11-14-2011 09:58 AM
Merlin75 Be careful of Hella 500s or any that the glass is visible from the side as you may get a halo bounce back effect at night. Will try to post pics tonight. There are ways to remedy, but I wish I'd gone a different route to avoid having to fix
11-14-2011 09:23 AM
scottbabu I just installed PIAA's this weekend. Everything went fine until I had to connect the wire from the switch to an existing "hot" wire. I tapped into a brown wire and while the little led on the switch lights up and goes from red to green ... the lights themselves do not light up.
I have triple checked and everything in connected. Are there wires you tap into that don't have enough "juice" to power the lights?
(Don't mean to highjack your thread ...).
11-13-2011 07:11 PM
cu in oz Those are beautiful.............wow!!!!
11-13-2011 04:48 PM
kjeeper10 Ooh I like those
11-13-2011 04:24 PM
Xnewyorka
Quote:
Originally Posted by RMally View Post
Thanks for the reply's fella's....

TanManRubi......looks great, how about an exterior shot as well.

Thanks,
here ya go!
11-13-2011 04:18 PM
RMally Thanks for the reply's fella's....

TanManRubi......looks great, how about an exterior shot as well.

Thanks,
11-13-2011 04:16 PM
Xnewyorka here's where I put the switch.
11-13-2011 04:14 PM
Xnewyorka Rigid Dually LEDs from the inside. These don't block my view at all...just installed today.
11-13-2011 01:14 PM
Dogface Good questions and good answers. I would have asked the same.
11-13-2011 01:13 PM
Xnewyorka I just added the Rigid Dually LEDs...they are nice n small with great light output. Don't block my view at all. Wiring is straight forward, directions are easy. I went with KC windshield mount brackets, I thought they put them in the best position. Switch is in the front lower dash by my right knee...there is a good amount of room back there for the wires and it hides the small switch well.
11-13-2011 12:08 PM
phottomatt
Quote:
Originally Posted by RMally
I was thinking of adding some windshield lights to the JK but had a few basic questions.

1. How much of the windshield is blocked in the left and right corners? Can someone post a picture from sitting behind the steering wheel.


I don't have a pic of this but my KCs are easy to see but don't really block your view much

2. Wiring the set-up...I read a few threads about install, but where do you attach the interior switch...do you need to cut a hole in the lower dash.


I put my switch right above the left front speaker, there are a few different spots. You will just have to hold the switch in place and see which you like best.

3. What is a good all black light kit out there, is there any you should stay away from.


I have the black KC Daylighters 100 watt, they are amazing.

4. Is it as simple as bolting right to the existing windshield bolts and running wires under the cowl.


There is a mounted you attach the the windshield hinge with the existing bolts, easy peasy.

5. What is a good size and wattage to get.


My 100 watt/ 6" are more than enough for me.

Thanks,
John
11-13-2011 11:57 AM
RMally
Windshield lights....few basic questions.

I was thinking of adding some windshield lights to the JK but had a few basic questions.


1. How much of the windshield is blocked in the left and right corners? Can someone post a picture from sitting behind the steering wheel.

2. Wiring the set-up...I read a few threads about install, but where do you attach the interior switch...do you need to cut a hole in the lower dash.

3. What is a good all black light kit out there, is there any you should stay away from.

4. Is it as simple as bolting right to the existing windshield bolts and running wires under the cowl.

5. What is a good size and wattage to get.

Thanks,

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:38 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC