Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 1997 TJ Jeep Defroster Problem

Join Wrangler Forum Today


Thread: 1997 TJ Jeep Defroster Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-27-2014 05:09 PM
nemo thanks fourjeeps, that got mine to pass inspection
12-01-2013 06:05 AM
FourJeeps
Easy Solution

It seems as though the arm inside the heater box is broken. A simple coat hanger works to manually open the defrost flap. Push down for open. Up for close.
11-29-2013 07:38 PM
99_tj Same thing for me, tai_66. Pushed the black piece in the hole, now it seems to work. Don't know about the fan sound, I haven't heard it.
10-23-2013 12:53 PM
mechanic the replacement was made out of cast aluminum and is working very well!!
10-21-2013 06:12 PM
mechanic i have the same problem. i am working on putting a metal replacement part together
10-26-2012 07:35 PM
tai_66 I've had this problem with my 99 TJ, and reading this thread almost a year ago I had diagnosed it as being one of these actuator levers. But then winter made me not want to be out doing it, and then I didn't need defrost. Now winter is coming again, so I decided to go about fixing it. Took the seat out today, and I don't know if the lever is broken or what, but definitely "loose." The one giving me trouble is the defrost actuator, and the defrost has never worked since I got the jeep. I just pushed the black plastic piece into the hole, and it seemed to kind of "seat," and now my defrost and everything works for the first time, yeah!

But not so fast... Now the fan is making a sound like it is hitting something, regardless of what setting the heater is on (vents, floor, defrost, or combos). I dont know if I somehow pushed something into the fan or...? And if so, the fan might eventually knock the plastic piece back out again? As you can tell, I'm definitely a novice at this. I was reading about removing the fan motor and checking if some sort of debris is in the housing, but couldn't figure out how to do that. I removed the battery and found what appeared to be where I would access the fan (which I think is actually located above the passenger foot area), but I wasn't sure, so didn't mess with it.

Any advice from anyone on this would be greatly appreciated.
08-24-2012 07:34 PM
The Heep Finished it last night. First time my vents have worked in 10 years. Sweet.
08-24-2012 05:32 PM
Ripsaw Yep, the lever worked the rest of winter and still does to this day. The long skinny plastic bit is really just to keep it in place, the real function is the star shaped gear piece.
08-21-2012 07:32 AM
The Heep Ripsaw, it's been a while since you fixed your defroster, does the plastic lever still work? I just bought one to replace mine and I'm questioning how it's going to stay in, without the "long skinny part".
11-27-2011 02:54 PM
Ripsaw Ok so I finally got around to fixing it today. My problem was that the two plastic levers had broken, and the half with the star shaped gear and long skinny connector was stuck in the gear hole. I took a drywall screw and screwed it in there as tight as I could, and with the kicker panel taken off I used a pair of vise grips to pull on the screw and get out the remaining part.

Unfortunately only half it came out, the long skinny part stayed in. Knowing the skinny part was only there to keep the part in there and the star shaped piece controls the door, I took the new plastic lever piece I bought and reluctantly cut off the skinny part, leaving only the star shaped gear on the end.

In the end I connected the actuator back up with the plastic piece and got the defroster to work.

Tip for anyone doing this; take out the actuators, it frees up more room in the cramped quarters and allows you to put the plastic bit back on the metal lever before you reinstall it, just give the actuator a good pull and it will come out.
11-26-2011 01:10 PM
C-Rock I plan on giving the deck screw a shot and hope it holds through the winter, it's going to be too chilly to pull the old "Ace Ventura" going down the road. Thanks everyone for all the help.
11-25-2011 01:59 PM
Kozso I just fixed mine by running 1" deck screws through the broken lever into the piece still in the air box. Maybe not the best solution but my defrost and other settings now work, I'd say about 90% correct. Meaning there maybe a little air blowing through the defrost when the setting is set to floor, for example. I can live with that. Plus it may just be a temporary fix until I get a chance to fix it the right way.

All you need to do is familiarize yourself with the diagram Ripsaw provided and how the actuator arms work and position themselves as you change heater positions from floor to defrost. With the control set to the floor position, flap for the defrost will be closed. I screwed the broken lever back into position. making sure to go through the hole on the piece that was broken off in the air box. I then hooked up the actuator arms and round clips. That's it.

I hope this helps others.
11-24-2011 04:43 PM
Toofer My 99 TJ does the same thing. Does this year have the same issues?
11-24-2011 07:31 AM
punisher2010 my 97 is doing the same thing
11-24-2011 07:24 AM
Shelby427 Sorry but the only way to repair it is to do it right. Out comes the heater box.
You'll have to split the box to replace the door(s) that broke.

Nice weekend project for most. Not that hard of a job, it's just a lot of screws that need to be removed to do it, most of them identical, and the ones that aren't are easy to spot and return to the proper place.

And while you are in there, it would be wise to replace the heater core and evaporator. That's what I just did about a month ago.

Like said not a hard job, but once done it's not a job you want to do more then once.
11-23-2011 09:38 PM
Kozso I am having the same issue. 2 of the plastic levers are broken on mine -- the Panel/Demist Door and the Defrost Door. I got the L piece off the actuator arm without snapping/breaking the arm by removing the little clip and fishing the L piece out of the actuator arm.

The issue is how to fix. It appears that the lever that works the defrost door flap inside the air box broke off in the box itself. I can get a deck screw into the broken end of the lever but cannot fish it out of the hole. I think I am screwed and will need to take out the dash and the air box to fix it, unless anyone has any suggestions.

Excellent picture Ripsaw
11-15-2011 09:14 AM
C-Rock So how do we fix it without taking out the dash and the box?
11-14-2011 03:03 PM
Ripsaw Well I definitely know that the plastic lever is broken, if you are having the same problem I suggest taking the driver seat out, unless you're young and haven't wrecked your back yet, and get underneath the dash on the driver side by the pedals, and look to your left. That's where you should see the levers and whether they are broken or not.
11-13-2011 11:57 AM
C-Rock I have the same problem with the fan slamming an inside flap shut on a '97 TJ. It looks like of the plastic pieces at the end of the metal arm of the defrost actuator is broke. It's hard to see up there and I didn't think it was broke at first. I saw somewhere someone used a self tapping screw to connect the broken plastic pieces without taking out the entire box?
11-13-2011 10:31 AM
TreeClimber1 I'm not exactly sure, but I do believe the 97 and 98 heater boxes are unique to those years. It's not uncommon for the heater box pivot shafts to snap internally in the box. You may need a replacement heater box from a wrecking yard. There is a guy in Portland Oregon who specializes in TJ, and I sourced a box from him. He advertises extensively on Ebay. Good luck.
11-13-2011 07:43 AM
dmitchell28 I'm with you on paying someone else...that's why I have been religious about checking anything close to my problem on here hoping for a fix.
11-12-2011 03:54 PM
Ripsaw That's strange, at least with mine I know exactly what it is, just fixing it is proving to be a pain. I'm trying to avoid having to pay for someone else to fix it.
11-12-2011 01:09 PM
dmitchell28 I am having some of the same problems. If I keep the defroster on the first setting it does fine so to speak, but once you turn the fan up something slams shut and turns off the defroster to the windshield, BUT the vent defrosters for the window blow just fine.
11-12-2011 12:44 PM
Ripsaw
1997 TJ Jeep Defroster Problem

Ok, so the problem is that when I turn on the defroster it shuts off after about 1 second. I removed the kicker panel below the steering wheel and saw that both the panel mist and defroster L piece that goes into the hole in the panel were broken. I have both the pieces on order to be shipped, the main problem right now is trying to get the L piece off the actuator arm off without snapping/breaking the arm. Any ideas how to do this?

Here's a picture of the assembly that I'm dealing with.



Thanks for any help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC