Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Non-YJ Day, but... its my own fault I guess.

Join Wrangler Forum Today


Thread: Non-YJ Day, but... its my own fault I guess. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-29-2011 01:34 PM
sevenservices yup, went home at lunch to try and get 'er going. FOUND THE PROBLEM! As soon as I hooked up the jumper cables to my sable, the under dash lights came on.

been using them more often now that its getting dark around 5:30pm. All the kids have a hard time climbing in and out so I put the lights on to help them. ...oops.

On the bright side, (no pun intended) I noticed my battery does need a cleaning. And yeah, I made it to the gas station! I've been told that when the YJ's say empty, THEY ARE! No taking chances with 'em.
11-29-2011 08:20 AM
sevenservices
Quote:
Originally Posted by 95YamJam View Post
My battery gets weak after a 4-5 days. It's old though... Sorry bout' your luck. Mines ready for the coming snow but most likely i'll be in my truck with the plow.
I probably need to clean mine again, I was surprised how much voltage can short across the top of the plastic even with minimul grime on there. If anyone wants to try something and you have a volt meter, touch one side to your positive post of the battery and touch the other side to the (nonconductive) plastic on top of the battery. If you see any voltage at all, your battery is shorted across the thin layer of grime. You can poke around on different places and see the voltage change! Its crazy... I had a friend whos kept dying, it looked horrible. I showed him 11 volts going across post to plastic because of the grime! A little bit of baking soda and water goes a long way! It dilutes the acid, you can watch it foam up when you sprinkle it on. Scrub gently then rinse it all away and check for shorts on the plastic again once dry. The volt meter should not show anything when it is only touching the plastic.

By the way, I love your sig "A lack of planning on your part does not constitue an instant emergency on my part" my wife has that sign in her computer store!
11-29-2011 07:04 AM
95YamJam My battery gets weak after a 4-5 days. It's old though...

Sorry bout' your luck. Mines ready for the coming snow but most likely i'll be in my truck with the plow.
11-29-2011 06:57 AM
sevenservices
Non-YJ Day, but... its my own fault I guess.

darn it... I havn't drove the YJ in about 2 weeks because it was really low on gas. Had to run my sons friends home and was really low without passing a station. So, I figured I'd wait until I could just go straight to the gas station on the way in to work one day. Got up early, got in there to run 'er up for more gas and low and behold... my battery is completely dead from sitting two weeks and its pooring rain like heck, might get snow today as well.

So, Im stuck with the sable today. Heading home at lunch to jump 'er and get going again.

Is it normal for a YJ to run the battery dead sitting for two weeks? We didn't leave anything on??? Let me know if anyone has had a similar symptom. I know my battery is only about a year old and it ALWAYS cranks right up. Not sure whats up this time???

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:57 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC