Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Kentucky Jeep Forum > Need help finding someone for service.

Join Wrangler Forum Today


Thread: Need help finding someone for service. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-04-2012 05:47 PM
McBear Finally, a couple of weeks ago I am back to driving after my September surprise. Didn't get much troubleshooting done until the drive [cabin fever finally got me in the Jeep seat].

First thing I noticed was the blower was only going to defrost and then she mentioned that the A/C had not been working right. So, 1, 2, 3 I stopped the Jeep, went wandering under the hood and found a vacuum leak at the intake manifold.

After driving around for another 100 miles or so the computer finally reset its little brain and all was well. Now the blower works correctly, A/C does its thing and the low idle at cold start works as designed.

So, 1 4" ziptie on the vacuum connection to the intake and it is fixed. FYI, the rubber vacuum fittings on my 04 look like they are beginning to dry rot and that should not be happening in 8 years. Something to watch out for.
11-29-2011 09:35 AM
JeepAddOns-Chris Simple trick to narrow it down. I'm assuming you're not throwing codes?

When first trying to start the Jeep, turn it on (but not start) and wait three seconds for the fuel pump to pressurize the line. Turn it off, then turn it back on another few seconds and then try to give it a start. If it fires right up, then you have a fuel pressure problem. Fuel pump or (more likely) the check valve. Sounds simple enough, but unfortunately you have to drop the tank to replace/repair.
11-27-2011 11:37 AM
McBear We will try that today. Thanks.
11-26-2011 11:31 AM
4Jeepn Once its running is it okay, can it be driven? If so I would purchase a bottle or two of injector clean techron by chevron is good, then fill the tank up and run drive the jeep if she can, This might help. Also Our vendor on the site jeepadons is located in lexington I am sure if you PM chris he can help or recommend a shop.Jeep Wrangler Forum - View Profile: JeepAddOns-Chris
11-25-2011 02:00 PM
McBear
Need help finding someone for service.

Been out of forums for a bit. First it was business, then, in September I blew out my Quadriceps tendon and had to have it reattached to my knee. NOTE: this cuts out six months of your life while it heals. A 36.5" blood clot made it interesting....

Now to my problem. I can hear my wife starting the 04 LJ and it sounds like I have an injector problem. It takes several times to start it with high revving to finally get it to stay running.

I need to find a shop HERE IN LEXINGTON that she can take it to that will pay attention and solve the problem. I can't even get out to stick my head under the hood to take a look for at least a month.

Any recommendations would be appreciated. Not looking to hotrod the jeep, just get it running well again.

And it is also going to need tires before winter. Guessing I will just go stock rather than get her wandering through the mod route.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC