Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Fuel guage reading inaccurate after 1/2 tank

Join Wrangler Forum Today


Thread: Fuel guage reading inaccurate after 1/2 tank Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-29-2011 03:07 PM
YJman I was having the same problem. The problem only worsened as time went on. I took the sending unit out and could not get my hands on JUST the sending unit. Everywhere I looked, I had to buy the pump with the sending unit attached to it. I ended up cleaning the unit with electrical contact cleaner and it reads much more accurate now. Still want to buy a new one though.
11-29-2011 02:22 PM
flatline best guess is the sending unit.
11-29-2011 12:39 PM
CJXJYJ
Fuel guage reading inaccurate after 1/2 tank

1993 YJ 4.0 Fuel guage starts to read inaccurate just after a half a tank left. I have heard many a suggestion, being it the tank is warped, sending unit float being hung up or even the guage being messed up. Anyone have an idea in which of the three problems is the most common? I use my trip now but I am OCD and all 5 of my jeeps I love to keep as mechanically sound as possible.

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:45 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC