Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > No reception on an OEM radio

Join Wrangler Forum Today


Thread: No reception on an OEM radio Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-15-2012 08:22 PM
BlueRidgeYJ
Quote:
Originally Posted by damndirtydog
Somebody actually listens to AM radio?
Lmao.

Heard on the news in Canada AM stations are transferring to FM permits faster than new AM applicants. AM is dooooooomed!

Sorry flash, no idea on new(er) stuff.
10-15-2012 08:15 PM
damndirtydog
Quote:
Originally Posted by flash1034 View Post
Me too. I bought an 06 and have no AM reception. FM seems fine. Any ideas?

Flash
Somebody actually listens to AM radio?
10-15-2012 08:04 PM
flash1034 Me too. I bought an 06 and have no AM reception. FM seems fine. Any ideas?

Flash
01-02-2012 09:29 PM
rclarke How did the antenna situation turn out? I just brought home a 2010 and am running into the same problem. Did you figure out a solution
12-17-2011 03:37 AM
medic1555 I just located instructions to test the antenna. I'll give that a go.
12-17-2011 03:20 AM
medic1555 I was able to reach the antenna cable connection to the radio through the glove box opening. I unplugged the connection and plugged it back in making sure it was tight. Checked the other connection point behind the glove box and it too was tight. Still no reception. First I'm going to try replacing the antenna cable that connects to the radio. If that dosen't work I'll replace to antenna.
12-16-2011 09:59 PM
Sccafire Also look behind the glove box and make sure the antenna is connected.
12-16-2011 09:53 PM
Jma20a Pull the stereo and check the connection on the back of the unit
12-16-2011 07:50 PM
medic1555
No reception on an OEM radio

Just brought home a 2005 Wrangler X today and luv it!

My very first question has to do with the reception of my OEM AM/FM radio. I get absolutely no reception at all unless I stand outside the Jeep with my hand on the top of the antenna (then I can pick up a couple of local stations). I checked the antenna wire and the connection behind the glove box and the cable is firmly connected. I unscrewed the antenna, cleaned the threads, coated them with dielectric grease, reinstalled it...still no luck.
Any ideas or suggestions? New antenna?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC