Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > help please

Join Wrangler Forum Today


Thread: help please Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-20-2011 01:19 AM
RyanMcLovin it sounds like a mouse but over xmas break ometime ill take look at it or take it in.. i need to learn how to do these things by my self
12-17-2011 10:59 AM
Another Guy In A Jeep Same thing with mine and i havnt got around to fixing it. Iv narrowed down the noise to one pulley, which is the biggest one on the left lower part of the whole serpentine system. I know that there is a rubber piece behind the pulley that if warn, will make that noise but thats just one thing that could go wrong. Or could be u need a whole new belt
12-17-2011 10:55 AM
jcf Yes I did about 12 months ago
12-17-2011 01:27 AM
themoneypit jcf- did you change rims
12-17-2011 01:07 AM
jcf Just saw this:
http://www.wranglerforum.com/f33/whi...er-126602.html
12-17-2011 01:03 AM
jcf Could be a bad pulley, one of mine went out when I got a bunch of mud in all over the motor,they are cheap, or could be just dust in something or a belt squeeking. Also could be the heater fan. Have you turned the heater on & off a few times to check?
OR...........you have a mouse in there
12-17-2011 12:51 AM
RyanMcLovin
help please

there is a squeaking noise coming from the belt spinning i think but i hear it when the A/C is on heat. but youu can also hear it better when you open the hood. it sounds like a mouse.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC