Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > California Jeep Forum > Hi! Just got YJ, Los Angeles

Join Wrangler Forum Today


Thread: Hi! Just got YJ, Los Angeles Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-02-2012 05:47 PM
MNTNGOAT For ur cleghirn run
03-02-2012 05:46 PM
MickeYJ
Quote:
Originally Posted by MNTNGOAT
You can start a new thread
Whys that?
03-02-2012 05:35 PM
MNTNGOAT You can start a new thread
03-02-2012 04:42 PM
sawyert Theres plenty of people posting on this thread asking you to go with them haha! I would go but im in south san diego so LA is a bit if a drive for me. And the jeeps gettin worked on this weekend. I already sent you a pm with my group though so if you ever go south of LA look us up!
03-02-2012 04:28 PM
MickeYJ
Quote:
Originally Posted by sawyert
Don't be afraid to take your jeep out on a trail run because its stock. Just do a easy trail. I took mine out to pine valley which is easy and did just fine. Mind the fact of me get stuck once because i tried to do a little more than i should have but thats beside the fact haha. Cleghorn would be a nice trail to start off on. Just go with a group so you have people there to help you out on the trail and pull you out if you do ever get stuck, or have a spotter if your feeling uncomfortable in certain spots. Just take it slow and you'll be fine. Now go get that jeep dirty!
I don't have a group to go with tho
03-02-2012 04:11 PM
sawyert Don't be afraid to take your jeep out on a trail run because its stock. Just do a easy trail. I took mine out to pine valley which is easy and did just fine. Mind the fact of me get stuck once because i tried to do a little more than i should have but thats beside the fact haha. Cleghorn would be a nice trail to start off on. Just go with a group so you have people there to help you out on the trail and pull you out if you do ever get stuck, or have a spotter if your feeling uncomfortable in certain spots. Just take it slow and you'll be fine. Now go get that jeep dirty!
03-02-2012 11:58 AM
MickeYJ Kool.

Hey guys I've heard cleghorn trail is easy. Anyone planning on going up there any time soon?
03-01-2012 02:39 PM
turdhurdler
Quote:
Originally Posted by MickeYJ
Question. I have a smittybilt soft top on my YJ and u guys know how the TJ and newer wranglers have those quick release latches things on the front of top to take it off? Well mine is not like that. On mine I have to loosen the back so that it's loose enough for it to come off the windshield channel....

Do they sale a kit to add this option on? Curious,
Not sure if there is an option, but the stock style has worked wonderful for me.

If you need any suggestions just ask.

Jeff
03-01-2012 12:56 PM
MickeYJ Question. I have a smittybilt soft top on my YJ and u guys know how the TJ and newer wranglers have those quick release latches things on the front of top to take it off? Well mine is not like that. On mine I have to loosen the back so that it's loose enough for it to come off the windshield channel....

Do they sale a kit to add this option on? Curious,
02-29-2012 09:32 AM
MickeYJ
Quote:
Originally Posted by BillG.OTD

They are better in the sense that they are lower, beacuse the higher the number of the gear, the lower the gearing is. My 6 had 3.07s when I bought it (as did alot of them) and when i regeared, I couldnt have given my old gears away. You would have plenty of takers for 4.10s. (same gears they put in a stock Rubi) They are still a bit on the high side and the most popular gears are 4.56, 4.88, 5.13 etc. The bigger the tire and the harder you off road = lower gears. Make sense?
Ooooooh ya I got it.
Well at least I also have the Rubi wheels/tires lol
02-29-2012 09:01 AM
BillG.OTD
Quote:
Originally Posted by MickeYJ View Post
So mine has better gears than a 6cyl?
They are better in the sense that they are lower, beacuse the higher the number of the gear, the lower the gearing is. My 6 had 3.07s when I bought it (as did alot of them) and when i regeared, I couldnt have given my old gears away. You would have plenty of takers for 4.10s. (same gears they put in a stock Rubi) They are still a bit on the high side and the most popular gears are 4.56, 4.88, 5.13 etc. The bigger the tire and the harder you off road = lower gears. Make sense?
02-29-2012 02:26 AM
MickeYJ
Quote:
Originally Posted by BillG.OTD
I guess that because the 4s got 4.10s and the 6s got 3.07s or 3.73s. That is a good thing!
So mine has better gears than a 6cyl?
02-29-2012 01:29 AM
BillG.OTD I guess that because the 4s got 4.10s and the 6s got 3.07s or 3.73s. That is a good thing!
02-29-2012 12:50 AM
MickeYJ
Quote:
Originally Posted by BillG.OTD
Yeah, So what's so custome about your rear end?
Means its bad ass!!! Lol jk here's what it means....

"Note: Some model 35's are known as Dana 35C's. The C does not stand for c-clip, it stands for custom. This means that it was shipped to Chrysler incomplete from Dana and then Chrysler finishes the build."
02-29-2012 12:48 AM
BillG.OTD Yeah, So what's so custome about your rear end?
02-28-2012 11:10 PM
MickeYJ Nvm lol I researched... It's a Dana 35C (custom)
02-28-2012 11:03 PM
MickeYJ Sorry. Another question... So... I know I have a Dana30 n the front... And the Build Sheet says I have 4.10 gears n the rear.. What axle would this be? D35?




02-28-2012 10:50 PM
MickeYJ Thank u!!!! Yes makes sense lol
02-28-2012 10:36 PM
LouieDelTorchio
Quote:
Originally Posted by MickeYJ
Guys I have a question... So my 4x4 has settings 2H,4H,N, and 4L... I always have it on 2H..... Is that where it's supposed to be? Or on neutral? I'm in LA... So for regular streets/fwy what's the most appropriate setting ? Thx
Always have it in 2H, since you don't need all four for traction on the road. Neutral will not allow you to move :P 4H and 4L you only need offroading or if you need extra traction. Hope this helps
02-28-2012 10:20 PM
MickeYJ Guys I have a question... So my 4x4 has settings 2H,4H,N, and 4L... I always have it on 2H..... Is that where it's supposed to be? Or on neutral? I'm in LA... So for regular streets/fwy what's the most appropriate setting ? Thx
02-28-2012 08:02 PM
MickeYJ I've gotten that I look like Tina Fey several times
02-28-2012 07:59 PM
MickeYJ
Quote:
Originally Posted by LouieDelTorchio

You almost look like Briana Evigan. Maybe?
Lol no way!
02-28-2012 07:37 PM
LouieDelTorchio
Quote:
Originally Posted by MickeYJ

I do?
You almost look like Briana Evigan. Maybe?
02-28-2012 07:33 PM
Xjman1 Fuel filter, vapor locking?
02-28-2012 12:33 PM
OklaTJ Welcome to the Forum! I don't live In CA But I'm in town I'll be in LA in the morning maybe I'll see a WF sticker out there
02-28-2012 12:23 PM
Another Guy In A Jeep Could just be a mix of everything...ya know, a YJ is pretty old.
02-28-2012 12:21 PM
MickeYJ Seriously.. It was doing it as I was driving on the freeway on my way to the shop... Then I got there and waited like almost 2hours cause he woke up late lol then he got n the car and drove just fine!! Then I asked his other mechanic there to drive it too and nope.. Everything was fine! They checked oil pressure... Spark plugs and cables and idk what else and nothing!
02-28-2012 12:11 PM
Another Guy In A Jeep
Quote:
Originally Posted by MickeYJ View Post
Ya so idk what's going on. When it started doing that a couple weeks ago, I took it to an all-jeep shop I go to, and darn jeep started working fine when they tried to duplicate the problem! They couldn't find anything wrong with it!!!! The mechanic thought said I was just looking for an excuse to go see him lol
hahaa. Yah I dont got a clue what the problem could be then.

and I hate it when they say they "cant duplicate the problem". Iv gotten that before.
02-28-2012 12:05 PM
MickeYJ
Quote:
Originally Posted by Another Guy In A Jeep
lol I hear ya, my speedo is off by 5
Ya so idk what's going on. When it started doing that a couple weeks ago, I took it to an all-jeep shop I go to, and darn jeep started working fine when they tried to duplicate the problem! They couldn't find anything wrong with it!!!! The mechanic thought said I was just looking for an excuse to go see him lol
02-28-2012 12:02 PM
Another Guy In A Jeep lol I hear ya, my speedo is off by 5
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC