Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Clutch question......

Join Wrangler Forum Today


Thread: Clutch question...... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-03-2012 11:55 AM
freeskier Sounds like it could be the transmission input shaft bearing if the sound goes away when you push in the clutch pedal (clutch disengaging).
01-03-2012 10:25 AM
mtb011
Clutch question......

So I'm about 3 weeks into having my beautiful 1999 4.0 6 Wrangler sport....and 2 days ago was confident enough to take it offroading for the first time....dropped it into 4 high while doing a slow cruise and neutral, and off i went! Finish everything up, get back on the road, turn off the 4wd, start accelerating down the highway, and i get this horrible kinda whirring mechanical sound coming from the jeep, thought it was the 4wd stuck so i did the steps to turn it on and off...no bueno, The noise did go away, and now it only happens when i get past 2,000 rpms in any gear...to toubleshoot, i put it into neutral and gently gunned it up, past the 2,000 mark; and the sound did not re-occur....So is this a clutch going bad? I will say this is my first manual, and there was a learning curve...missshifts, stalls, and one time i didnt have the clutch fully depressed before i shifted....nasty sound haha......I have gotten the shifting down now though ......anyways, so whats a bad clutch sound like? Could this signify any other problems?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC