Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 07 wrangler intermittent wiper fix

Join Wrangler Forum Today


Thread: 07 wrangler intermittent wiper fix Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-12-2012 10:19 AM
nwbronco I am down to the TIPM now. I did the motor fix, and swapped out the multifunction switch. No joy.


Bob K.
01-11-2012 12:10 PM
wjfawb0 I'm glad it's working for people. I hate spending a bunch of money on parts or service when it could be a simple problem to fix.
01-11-2012 11:37 AM
Bambachic I just had to join to say thank so much you for this! IT WORKED! My daughter has her driving test and has to demonstrate operational wipers, this saved us time and money and it was very easy to do, even for a 39 year old mom with 4 kids! Thank you again!
01-10-2012 12:56 PM
kenb1023 This is a keeper for my "What do I do now" file
Thanks
01-10-2012 11:54 AM
Just1Spartan Firstly, great break down, wjfawb0, very informative.

I also have a 2007 JK and luckily I haven't had any problems with my wipers returning to their home position or any other issues with their movement. What I have noticed is, when I first get in my Jeep and turn the ignition, regardless of what setting my wipers are on, they will not turn on. I have to switch them to off and then back to whatever setting is required.

Would this problem be caused by the same issue described in this thread, or is this something totally different? Anyone experienced this? Thanks, guys.
12-08-2011 05:31 PM
wjfawb0 Try sanding/scrubbing the tips of the fingers. I did that to mine when I took it apart out of habit (I work on electronics a lot). A member on another jeep forum typed this about taking it back apart after a failed attempt:

"I took it out again and cleaned the fingers as you suggest. Also disconnected battery as suggested in another post. The wipers work as they should. Thanks for help."

Connections usually cause the problems when you're dealing with electronics. It sounds simple, but a little oxide buildup on the tips of the fingers could be the problem. Shitty thing is the problem is likely to come back over and over again with the design on this sensor wheel. Hopefully it will last for years. I sold my jeep after 50,000 miles due to oil consumption along with a host of other electrical problems.
12-08-2011 05:14 PM
blackforestgreen bump
12-08-2011 02:49 PM
k7svv Well, you really had me excited because your description of the symptoms matched mine exactly and mine is also a 07 but no luck so far. I have had the motor assembly out three times so far. The first time I wiped the grease off on the disc and the contact fingers. This caused the symptoms to change and now ot is a solid bug. The delayed sweep doesn't stop and the blades stop at wherever they happen to be when the wipers are turned off. The second time I cleaned the disc and the contacts with isopropyl alcohol and nothing changed. The third time I reformed the contact fingers so they appear a bit more pressure on the disc and still no change. It is currently sitting in the driveway with the battery disconnected and I am about to go out there and reconnect the battery and give it another try. Wish me luck.
12-06-2011 12:52 PM
wjfawb0 On another forum one of the members wipers didn't work until he took it apart a second time and cleaned the contact finger tips and made sure they were biased to press against the wheel adequately. I'm just throwing that out if you try the fix and cleaning the wheel alone does not take care of it.

07 wrangler intermittent wiper fix - JeepForum.com
12-06-2011 12:44 PM
wjfawb0 I believe I also bent the contact fingers out a bit to make sure they had good contact with the wheel when I did this fix.

About the grease on the worm gear, I'd leave it alone so that the worm and ring gearm stay lubed. It's a crappy-ass design to allow the grease from the gears to get to the sensors that determine position.

If you perform this fix and the wipers don't work, I would inspect the wires to the fingers and also make sure the spring fingers make good contact with the metal/plastic wheel. This appears to be the only feedback the computer gets to control the direction and position of the wipers.
12-06-2011 12:12 PM
Robicon Sweet, I knew it had to be a homing sensor not the motor. Thanks for the nice proceedure!! Soon as I get home, its gettin' fixed.
08-26-2011 11:25 AM
WranglersRule Hey Guys,
I have an '87 Wrangler and have no power to the wiper motor or washer pump. The switch checks out okay. The wiring diagram in my shop manual shows a 5.3 amp fuse but not a location. For the life of me, I can't find a fuse or relay for the circuit anywhere. There is no 'Power Distribution Center' under the hood like on later models, so I am at a complete loss as to where else to look.
Any ideas?
08-25-2011 09:13 PM
msattler
Quote:
Originally Posted by msattler View Post
Just put it all back together to see no difference. Then I read over the instructions and realized you cleaned the entire disc So clean the entire face of the disk, what about the little turning screw toward the back? There's gobs of grease there?

Also, is there a part number for the motor if one just wanted to replace it?

Thanks!

-Marcus
Cleaned the disc this time, and closed it back up, no difference. I may try disconnecting the battery again to see if it helps.

A part number would help, it looks like the previous owner or someone tried this as well as one of the tabs of the cover was snapped off.

Thanks!
08-25-2011 08:05 PM
msattler
Quote:
Originally Posted by kik View Post
This is a great thread. Thanks.
Just put it all back together to see no difference. Then I read over the instructions and realized you cleaned the entire disc So clean the entire face of the disk, what about the little turning screw toward the back? There's gobs of grease there?

Also, is there a part number for the motor if one just wanted to replace it?

Thanks!

-Marcus
06-06-2010 11:16 AM
beachbuggy Sweet... Most valuable post I have read yet. 45 mins and working perfect. Thanks!
03-09-2010 08:52 PM
billyb I was just looking for a thread like this. Going from lo to off, my wipers end up 3 inches from home. If I turn them to intermittent, they can find home. Only a mild annoyance at this point, but these things don't usually get better. May have to try this some lonely weekend.
01-15-2010 03:37 PM
johnybolt Great job!! Very useful and imformative.
01-15-2010 09:44 AM
whiteyj Certainly a better linkage system than the YJ has!
01-15-2010 08:21 AM
h2otoo Step by step, and with photos. Nice job! Those are the kind of instructions I need, for sure (though my wipers are working fine, for now).

Bob
01-15-2010 08:16 AM
kik This is a great thread. Thanks.
01-14-2010 06:45 PM
wjfawb0
07 wrangler intermittent wiper fix

The windshield wipers on my 2007 Jeep Wrangler started having problems several months back. At first they would randomly not find home and cycle an extra time or two before they finally stopped. Eventually the home position ended up a few inches up on the windshield instead of at the bottom. Then intermittent on the wiper settings yielded two wipes, then pause. Four wipes, then pause. Seven wipes, then pause etc, etc. Finally intermittent settings yielded continual wiping as if it were on low speed setting. A single wipe command would cause the wiper to stop whenever you released the stalk on the steering column. You had to manually home it or turn the wipers on to get it near home position.

I've worked on electronics involving encoder wheels and sensor flags to indicate "home" positions much like a crank or cam position sensor works, so I figured it was a flag or mechanism of some sort that wasn't working properly. Tonight I removed the wiper motor to see if I could fix the problem. The problem ended up being grease from the worm gear mechanism contaminating some contact fingers.

This takes 30-45 minutes and only requires a few torx bits, a couple sockets, a flathead screwdriver and something to clean up the grease with.

Use you fingers to lift the plastic cap covering the nut securing the wiper arms to the splined studs on the wiping mechanism. Spreading the plastic outwards on the sides allows it to easily pivot up. Remove the 13mm nut holding the wiper arm on the splined stud. Now pivot the wiper arm vertical, and lift it off the splined stud.



Remove four torx screws holding the cowl down, and then use a large flathead screwdriver to pry up and out the two plastic fasteners securing the screen under the hood. A trim panel tool you can get at Autozone or Advanced will make this easier. Lift the cowl up and then forward to release two plastic feet near the bottom of the windshield. Rotate the back end up and lift off the cowl and plastic screen. Lowering the hood will make this step easier, but it is not necessary.





Disconnect the wiring to the wiper motor by releasing the red plastic lock tab, pressing the catch and pulling. Remove two 10mm bolts holding the wiper assembly to the jeep. Lift the wiper assembly up and out of the cowl area. Note the rubber foot sitting in a hole under the motor.



Remove three torx screws holding down the cover on the gears and position indication portion of the motor. Remove the black plastic cover by releasing two plastic catches on the cover. Careful, they are likely brittle and might break.



More views of the wiper motor assembly:
http://www.fawbush.org/images/07_wra...wiperfix_6.JPG
http://www.fawbush.org/images/07_wra...wiperfix_7.JPG
http://www.fawbush.org/images/07_wra...wiperfix_8.JPG

After lifting off the cover you will see how the grease from the worm gear mechanism has contaminated the copper spring fingers which allow the jeeps electronic control module [ECM] to determine wiper arm position.



Clean the face of the metal/plastic disk and the contact fingers. Reassemble in reverse order and the ECM should be able to find home again (for a while).


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC