Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Teraflex 2.5" BB + 35x12.50 STTs ... why am I rubbing when I turn?

Join Wrangler Forum Today


Thread: Teraflex 2.5" BB + 35x12.50 STTs ... why am I rubbing when I turn? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-19-2012 03:47 PM
MD_Jeep
Quote:
Originally Posted by clvnmcd
I would be willing to bet you are rubbing on the front air dam if you have a stock bumper set-up. I too have a 2.5" teraflex lift (coil) and 35" tires. They only rubbing occured at full turn with the front Air dam. a quick trim with a box cutter, eliminated that problem and looked better as well.
I am running exact same setup and it doesn't rub at all but I got rid if the plastic air dam when I put on a stubby bumper and skid plate.
01-19-2012 02:25 PM
clvnmcd I would be willing to bet you are rubbing on the front air dam if you have a stock bumper set-up. I too have a 2.5" teraflex lift (coil) and 35" tires. They only rubbing occured at full turn with the front Air dam. a quick trim with a box cutter, eliminated that problem and looked better as well.
01-19-2012 01:44 PM
TeraFlex
Quote:
Originally Posted by GoBlueGigEm View Post
Tonight my wife and I should both be home at a decent hour and can take a look see. I'll have her turn it lock to lock and we'll see what happens.

(BTW, if anyone clicks on this and wonders about TF, I really like the 2.5" kit. Rides like stock, no alignment issues, hardest part of the install was getting the trackbar bolts off.)
Thanks for buying TeraFlex!
01-19-2012 01:20 PM
GoBlueGigEm Thanks to both of ya, BTW.
01-19-2012 01:18 PM
GoBlueGigEm
Quote:
Originally Posted by Revyjku08 View Post
Try adjusting your steering stops to avoid the rubbing.

The steer stop bolt is located on your front left and right steering knuckles.

Using a 9/16" socket, remove your Jeep JK Wrangler’s steer stop bolts.
Start with (1) 3/8" washer in each side. Retighten bolt. Then test.
Add more if needed.
Hadn't thought about that because I'd rather not lose the turning radius, but if it's what I gotta do it's what I gotta do.

Tonight I'm going to have my wife turn it lock to lock and get under there and take a good close look. I gotta get dirty to reattach the rock rails anyway, might as well see what I can find then, too.
01-19-2012 01:15 PM
GoBlueGigEm
Quote:
Originally Posted by TeraFlex View Post
Are you rubbing on the factory bumper and front air dam?
Tonight my wife and I should both be home at a decent hour and can take a look see. I'll have her turn it lock to lock and we'll see what happens.

(BTW, if anyone clicks on this and wonders about TF, I really like the 2.5" kit. Rides like stock, no alignment issues, hardest part of the install was getting the trackbar bolts off.)
01-19-2012 12:10 PM
Revyjku08 Try adjusting your steering stops to avoid the rubbing.

The steer stop bolt is located on your front left and right steering knuckles.

Using a 9/16" socket, remove your Jeep JK Wrangler’s steer stop bolts.
Start with (1) 3/8" washer in each side. Retighten bolt. Then test.
Add more if needed.
01-19-2012 12:02 PM
TeraFlex Are you rubbing on the factory bumper and front air dam?
01-19-2012 11:49 AM
GoBlueGigEm
Teraflex 2.5" BB + 35x12.50 STTs ... why am I rubbing when I turn?

- Also, I've trimmed the pinch seam and haven't put my rock rails back on yet.
- What used to be my rear sway bar links are moved to the front and are on the inside, with the nuts on the inside, giving the most room possible.
- My wheels are 17x9 with -12 offset, this *should* be 4.5" backspacing, according to this calculator, meaning I don't need spacers: Custom rims, wheel tire packages for your ride - RIMSnTIRES.com.

But ... when I turn full lock I get rubbing in the front. What are the likely culprits? I've tried the search function here and through google and can't come up with a good answer.

As an aside, I have Bushwacker flats, too, and haven't had the time to put them on yet, but those would only seem to help with vertical, rather than horizontal, movement of the wheels/tires relative to the body.

Any help with the likely culprits for this rubbing would be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC