Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > top of radiator?

Join Wrangler Forum Today


Thread: top of radiator? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-27-2012 11:38 AM
freeskier
Quote:
Originally Posted by CoyoteOn2
Sorry can't help ya there. But I do notice your Hose Clamps. You might consider
changing them the to the Ideal Worm or Screw type of clamp. Those Spring Clamps
are worthless and can FAIL at the worst possible time. (I won't say how I know,
just take my word on it.)
I would completely disagree. I hate the worm screw caps because they come loose over time. The factory constant pressure ones however do not. I still have the original factory clamps on mine except for the lower radiator hose where it goes on the water pump. I have never had an issue with the factory clamps and I have never had them leak, I have though had issues with the worm gear clamp holding the lower hose to the pump.

Obviously though different experiences are going to warrant different opinions.
01-27-2012 11:26 AM
spy
Quote:
Originally Posted by Crazyflyingplastics View Post
If I knew it was just a piece of foam, then I wouldn't have been worried. Now I know it's nothing I need to worry about. I am hitting up the trails next weekend, so I want to make sure everything is ready to go.

Thanks to all for the responses, looks like nothing I need to worry about then. Off to the trails soon!
O Trails! well you should have said so LOL, I thought you were one of those picky people lol

Good luck out there and be safe
01-27-2012 10:36 AM
obidya yeah, that piece of foam is more for protecting your fingers than anything else.
01-27-2012 07:48 AM
Crazyflyingplastics
Quote:
Originally Posted by spy View Post
really your worrying about a peice of foam...
Sorry don't mean to be an asshole but holy shit haha, Looks good!
If I knew it was just a piece of foam, then I wouldn't have been worried. Now I know it's nothing I need to worry about. I am hitting up the trails next weekend, so I want to make sure everything is ready to go.

Thanks to all for the responses, looks like nothing I need to worry about then. Off to the trails soon!
01-27-2012 02:44 AM
jkaufman_95 Damn your engine is clean.
01-27-2012 02:22 AM
Jeep_guy3 That's just a cosmetic piece of foam to prevent dinging the fins of the rad at factory. Rip the rest of it off and call it good.
01-27-2012 12:45 AM
CoyoteOn2 Sorry can't help ya there. But I do notice your Hose Clamps. You might consider
changing them the to the Ideal Worm or Screw type of clamp. Those Spring Clamps
are worthless and can FAIL at the worst possible time. (I won't say how I know,
just take my word on it.)
01-26-2012 11:09 PM
spy really your worrying about a peice of foam...
Sorry don't mean to be an asshole but holy shit haha, Looks good!
01-26-2012 11:04 PM
DevilDogDoc Mine has a big rubber strip that runs from side to side and has plastic plugs tha fit into the holes that you see in your grill. I have no foam however, mine is an old one...
01-26-2012 05:42 PM
Crazyflyingplastics the first picture is the right side of the radiator. This next pic is from the left side, you can see where the foam/rubber starts. Nothing is seeping out of the radiator. I just wasn't sure what this is.
01-26-2012 01:59 PM
james.l.devore Crazy, I can't really tell from your picture but If the top has any seepage plan to relace it. I've gone through 2 radiators, aluminum and pressed plastic just dont work.......I dont know who the genious was.
01-26-2012 01:53 PM
Crazyflyingplastics
top of radiator?

I was checking all my fluids today and noticed this on top of the radiator. It doesn't look right to me. it looks like a piece of foam that should be running all the way across the radiator. wasn't really sure if I need to do anything or just leave it alone.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC