Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Extremely high idle after exhaust manifold change. Another possible reason!

Join Wrangler Forum Today


Thread: Extremely high idle after exhaust manifold change. Another possible reason! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-16-2012 06:30 PM
donofrionis man I'm going nuts over this, I ordered my replacement exhaust manifold from advance auto parts, put it all together and my rpms start high and slowly come back down. I found the same problem with the thickness of the manifolds! what did you use to grind them down?
01-31-2012 04:47 PM
98Tj_guy I went to lkq salvage and got the bolts for 33 cents and put them in, in the parking lot and when I started it up it was like a brand new jeep. It runs better and sounds better. Hell I've been driving it with that high idle for so long I killed it twice in the parking lot but I'm just glad to have it fixed. Thank you all for your help.
01-31-2012 02:13 PM
Junior815 Yeah I noticed that after it was shipped to me. But for 60 bucks I will let it ride till it goes. Hopefully then I will have the extra bucks to do it right. But for now its quiet and I can actually hear myself think besides the soft top and the big tires. Speaking of which. Does anyone know if road noise is cut down inside the jeep if I use extended flares or is it just the perks! I dont mind just wondering.
01-31-2012 12:48 PM
jeepjones You should have figured there might be some problems just from the casting in picture # 2 not only does the casting have holes (porosity in the cast) but it's made in CHINA! Dare I say it, I don't think this is the last issue you will have with that manifold. Shoulda bit the bullet and gotten a header that is going to last, like one from BANKS.
01-30-2012 07:25 PM
wwch99tj No problem you welcome
01-30-2012 07:19 PM
98Tj_guy Thank you. I called lkq salvage and they don't have any wranglers but told me what other vehicles have the same bolts and will only charge me 25 cents each bolt. But thank you and I'm hoping that will fix my high idle problem.
01-30-2012 05:52 PM
wwch99tj They are a standard ⅜-16 bolt but here's a link
http://www.google.com/m/products/det...21800345#prd:o
01-30-2012 03:32 PM
98Tj_guy I've had the same problem and I replaced the gasket which was needed badly. Well when I replaced the gasket I noticed that I'm missing 3 or 4 bolts on my exhaust/intake. So do yall know where I can get those bolts and do you think that will fix it? I've put a new iac valve pb it thinking that will fix it and if the bolts don't fix it ill buy a new Tps but is like to fix it without replacing everything.
01-30-2012 09:52 AM
wwch99tj So apparently someone had replaced it once before. My factory 1 on my 99 doesn't have the flat spots like that. Glad you found a problem
01-30-2012 09:41 AM
Junior815
Extremely high idle after exhaust manifold change. Another possible reason!

Please excuse this extra long post. Just throwing out my story to try and help the next guy! I am new to wrangler forum as of this year. First I would like to say thank you all for the great posts. This has been a great tool for helping keep this jeep on the road. My 97 wrangler 2.5 cyl had the notorius loud exhaust leak coming from the engine bay when I bought it. After looking on here I came to the assumption that the manifold was most likely cracked. I ordered an exhaust manifold off of ebay. Stock oem style. Two days ago I began the tear down of the siamese setup that is a jeep 2.5 cyl. Everything went great, I was pretty excited when I found no broken bolts and everything came apart in a little over two hours. My exhaust manifold had a gaping crack in it! During reassembly everything went back together pretty easily to. Over all I felt pretty good about it, until I started it up! The Jeeps rpm's went straight to the roof. Maxing out at 4000 before I killed it. As I sat there in disbelief I started to wonder what was ahead of me. Let me say first, I should have went straight back to the intake manifold and exhaust I had just removed and put back on. But I didn't think that's what it was. (Faith in my mechanical abilities!) I checked all my lines and connections for leaks. Tried the reset of the computer. Then checked my iac valve. Nothing out of the ordinary there. Finally I realized I was taking the intake back off! I removed all of it to check for any issues. Found nothing. The next day I went out and bought another gasket and tbi gasket and o-rings for the fuel Injectors. Put it all back together again. Crossed my fingers and started it. Same exact thing! Rpm's through the roof. By this time I was pretty well ticked off. I jumped on wrangler forum for some help. Found a few posts about this issue. And basically came to the assumption again that my issue was way to much leakage around the intake manifold. Back to the garage I went. During the teardown process I found what I thought could be my problem. I happened to notice that one of my lower bolts that tightens down on the intake and exhaust manifold did not seem to be touching the intake side. Then I noticed the issue. This is just something to check. Not saying it is the problem. But it was mine. I wish I would have checked it from the beginning. My ebay exhaust manifold was nearly an 1/8" thicker than my intake manifold! I looked at my old cracked manifold and sure enough it had tabs grinded down for the mounting spots! I don't know if my part was defective or that's the way it comes. I was able to grind flats into the manfiold where the four mounting spots were. Reassembled and tried it and wouldn't you know it purred like a kitten! I would like to just say, for future reference for anyone who has this issue. Save yourself the time and headache. Check the work you did. Not everything else it could be. Hopefully this helps someone in the future. Thanks for the time. I am going to try and post a few pics so you can see what my issue was! Thanks. Below are the pics. Old manifold, new manifold with flats for mounting and the jeep in the garage getting fixed. Nothing out of the ordinary here!


Attachment 93753


Attachment 93754



Attachment 93755



Attachment 93756

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC