Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Arkansas Jeep Forum > starting issue, need help

Join Wrangler Forum Today


Thread: starting issue, need help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-02-2012 11:59 AM
arcountryboy
starting issue, need help

I'm a old school SBC guy, this new stuff confuses me. I have a 98 TJ 2.5 liter 5 speed. Been running fine until I left for lunch today. Started up and died instantly. Turned over a few times and nothing. I gave it a little gas and it fired right up, idled down real low, then came right back up to about 700 rpms. Runs smooth after that. Every single time you shut it off, you either have to give it gas to start it, or turn it over about 10 times. Fuel pump kicks on instantly, fuel rail when turned off for an hour still squirts gas out about 4 inches, when running all the way to the fender almost. Though it might be the check valve bleeding back, but if you kill it and start it back less than 3 seconds later, same issue. Any idea's? Maybe the throttle position sensor?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:33 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC