Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Jeep nightmares... Please help!

Join Wrangler Forum Today


Thread: Jeep nightmares... Please help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-16-2012 06:52 AM
biffdumas ok, the jeep gods win. I finally broke down and am am taking it to a jeep specialist. This is the first time in my life I havent been able to fix a vehicle. I know with the timing not right and i cant get it right I only serve to cause more damage than i can afford. Thanks everybody for your help, I will post what happens with the Specialist as soon as I know.
02-15-2012 08:24 AM
biffdumas Oh, I have a new fuel filter and a newish fuel pump
02-15-2012 08:01 AM
biffdumas Ok I will try that, and let you know.
02-15-2012 05:55 AM
Nas.a7x
Quote:
Originally Posted by olbaid_83
fuel pump maybe? Sounds kinda like the problem i had on my r1 not too long ago. Fuel filter was clogged and pump was going out. Try that and gl
x2
02-15-2012 02:33 AM
olbaid_83 fuel pump maybe? sounds kinda like the problem i had on my r1 not too long ago. fuel filter was clogged and pump was going out. try that and gl
02-15-2012 12:58 AM
1989JEEPYJ Bump I'm curious to see what the deal is. Sorry I couldn't help but there are jeep gods on here so you should get it figured out.
02-14-2012 11:42 PM
biffdumas
Jeep nightmares... Please help!

ok , I have a 90 jeep 4.2L 5spd Islander: I will give you the short form but know that i have been screwing with this POS for over a month and can't get it to run right. I have installed a new AX15 tranny, new universal joints, motor mounts, new carter BBD, new exhaust manifold and both gaskets, new harmonic balancer, coil, plug wires, plugs, dizzy, cap and button, I have eliminated all unneccesary vac lines, and nuttered it. Whew! Ok here is my problem: I cannot get it to run right. I have read all the varying opinions on setting timing and car set up and carb adjustment. I have all new vac lines on the ones I left. I have tried every and I mean every different setup on timing/carb adjustment. The damn thing still runs rough, and acts like it aint getting enough fuel through the carb or something. the only way it will run is with the vac advance disconnected and capped. otherwise it back fires so bad the cops have been called out three times this week, because my nieghbors thought someone had been shot. along the way I have had it running real good, until the test drive, and had issues which kept me from driving it. as of right now i am at 8* BTDC and idling around 1100 rpms. any lower and it act like it wants to die. It runs like it is on 3 cyl, and it misses . I have followed all the steps step by step and seem to be the only one having this issue. Oh i am running the stepper set 1/8" from carb wall with the SM disconnected. I am lost and very tired of working on this jeep without results. Can anyone help me? I am at my wits end.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC