Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > THE 730N RHR Q&A Thread

Join Wrangler Forum Today


Thread: THE 730N RHR Q&A Thread Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-28-2014 04:43 PM
1quick1
Quote:
Originally Posted by Snake_Eyes View Post
Can someone confirm what the latest software version number is and what the latest gracenotes version number is?

I see 2.6.0.0 and 5411 (respectively) on the MyGIG site, but my installed is 2.1.8.4 (I think) and of course the dealer says I'm on the latest.

Thanks
Will the dealer update the maps? I really hate the idea of buying $150 map update through Navteq when the damn Garmin Nuvi 40LM I've used just fine for the last 3 years was $120 and includes lifetime map updates.

My version appears to be very old.

07-28-2014 03:16 PM
Snake_Eyes Can someone confirm what the latest software version number is and what the latest gracenotes version number is?

I see 2.6.0.0 and 5411 (respectively) on the MyGIG site, but my installed is 2.1.8.4 (I think) and of course the dealer says I'm on the latest.

Thanks
07-28-2014 10:03 AM
wnbamiamisol Tony - Thanks for the reply. Who knows? I just made the 37 mile drive to Miami again and dropped the JKRX. Have a rental Ford Chrysler is paying for. Told them I don't want the JKRX returned until the problem is solved.
I have my fingers crossed they won't tear up my dash and cause another problem.

Quote:
Originally Posted by Tonyvasconi View Post
Bummer :-(. Thanks for the feedback. Although I'm sure they checked, did those techs check the switch on the right side steering column ... Maybe ?.....
07-27-2014 11:37 AM
Tonyvasconi
Quote:
Originally Posted by Tonyvasconi View Post
Bummer :-(. Thanks for the feedback. Although I'm sure they checked, did those techs check the switch on the right side steering column ... Maybe ?.....
Oops I meant to say left side
07-27-2014 12:45 AM
Tonyvasconi
Quote:
Originally Posted by wnbamiamisol View Post
Am wondering if anyone else has this issue. My Voice Recognition stopped working. Took my '14 JKRX to the dealership and spent 3 1/3 hours waiting for them to diagnose the problem. They called Chrysler who authorized replacing the 730n and the Microphone. Today, I returned to the dealer and waited another 2 hours for them to replace the 730n. It did NOT solve the problem. I will be heading back to the dealer Monday and leaving my JKRX. Anyone else have an issue with the VR on their 730n? All suggestions appreciated (except being told get a 430).
Bummer :-(. Thanks for the feedback. Although I'm sure they checked, did those techs check the switch on the right side steering column ... Maybe ?.....
07-26-2014 09:11 PM
tomthbomb
Quote:
Originally Posted by ndrugby View Post
Has anyone had an issue where not all your contacts sync to the address book? Mine seem to stop at the letter M. I've tried removing and syncing again. I'm using an iPhone 5c.

Thanks
Mine never sync'd on my Droid 2, RAZR MAXX or my brand new Galaxy S5. It shows the phone book syncing from time to time (no rhyme or reason, just about once a week) but it never works.
07-26-2014 12:27 PM
wnbamiamisol Am wondering if anyone else has this issue. My Voice Recognition stopped working. Took my '14 JKRX to the dealership and spent 3 1/3 hours waiting for them to diagnose the problem. They called Chrysler who authorized replacing the 730n and the Microphone. Today, I returned to the dealer and waited another 2 hours for them to replace the 730n. It did NOT solve the problem. I will be heading back to the dealer Monday and leaving my JKRX.
Anyone else have an issue with the VR on their 730n?
All suggestions appreciated (except being told get a 430).
07-22-2014 02:56 PM
ndrugby Has anyone had an issue where not all your contacts sync to the address book? Mine seem to stop at the letter M. I've tried removing and syncing again. I'm using an iPhone 5c.

Thanks
07-22-2014 02:13 PM
ndrugby
Quote:
Originally Posted by AUskier View Post
I've kept up with this thread, but I doubt I've read every post.... Anyway I was wondering if anyone has had a touchscreen malfunction. My touchscreen is "clicking" or "touching" buttons without being touched. It started happening very rarely a couple of months ago but has gotten progressively worse. Yesterday it was almost unusable.

Maybe I'm cleaning it wrong? I just use a damp microfiber cloth.

I guess I'm going to take it to the dealer but I wanted to see if anyone had any experience with this.
Quote:
Originally Posted by Tonyvasconi View Post
Did you solve your issue ... I also am having trouble with soft-keys on 6.5-inch touch screen for uconnect 730N/RHR. They do not respond to "touch" and/or they invoke without "touch", i.e. a radio preset with change the channel, or the Navigation system will ask for "press" to find map location, or OK button with turn on/off.
Any DIY fix, like you I want to avoid going into the dealer and get upsold to a new radio.

Thanks
T---
Quote:
Originally Posted by AUskier View Post
It definitely seems worse when the radio is dusty. But still happens some even with a clean screen. I can also see imperfections (pealing?) in what looks like a screen coating in the places I push the onscreen buttons a lot.

I like having an in vehicle navigation solution, but I'm about done with this unit. I haven't taken it in because of a crazy busy schedule but I'll update here when I do to see what they say.
Did you guys ever resolve this? I'm having the same issue. I had some bad peeling of a screen film as well. Eventually it got bad enough that I removed the rest. I wonder if that is the problem. But it's driving me nuts. Just clicking soft buttons randomly all over the place.

I wonder if swapping out just the LCD screen would fix it? They can be bought and should be fairly straight forward to replace.
07-21-2014 09:24 AM
1quick1
Quote:
Originally Posted by jwilson2598 View Post
I just did mine, they are VIN locked. They require a code that you get when you buy it and is tied to the VIN.
Wow.

Thanks for the info.

Quote:
Originally Posted by tomthbomb View Post
I got the notice for my 2012 this week. Can't imagine sending another $150 on this junk.
Me neither. I'm trying to find someone to trade me there 430N for my 730N. I am not a fan at all.
07-19-2014 11:01 AM
weissja36 I guess I lucked out because I've been using mine without any issues for about 5 weeks now. I actually really like it. Bluetooth, satellite, AM/FM works as it should. I've also used the Navigation on two road trips as well as around Los Angeles and it's been perfect. Maybe since my jeep was just purchased (but built it October 2013) I've got the updated software? My dealership sucks though so I wouldn't expect them to keep up on that.
07-19-2014 10:31 AM
tomthbomb
Quote:
Originally Posted by 1quick1 View Post
^^thx. Right now I have it hooked up and just not linked to my phone/bluetooth.

On a side note I'd like to upgrade the maps/software but saw the disc is $150 from Navteq and I think that's ridiculous.

Are these tied to a VIN or can I get one another way (i.e. find a used disc somewhere).
I got the notice for my 2012 this week. Can't imagine sending another $150 on this junk.
07-18-2014 09:17 PM
RonnieCaton Does the "POI (by name)" option work for anyone on the "Destination Entry"?

When I choose this option, it asks "Nearby or in City" and no matter how I answer, the screen automatically populates with a full page of options for TIERONE BANK. I never even get to the option of requesting the POI name. What's up with that?

With any other GPS (or phone) I can search for a business name, why can't you do this with the 730N. Very poor design.

While I'm on the topic, the arrival time info was off by more than an hour for a 5-hour trip on the first two trips I took with the new JKUR. Turns out, it only seems to work if I stick to major freeways. Driving rural highways, it seems to think the speed limits are 30 mph in calculating the arrival times.

Oh, and I the entire system froze on the return from one of those trips. I pulled off the road and turned the car on/off but it didn't help. Finally reset itself once I made a 5-10 minute stop somewhere.

I've had the 730N for 1.5 months now and am sincerely regretting the "upgrade."
07-18-2014 07:45 PM
jwilson2598
Quote:
Originally Posted by 1quick1 View Post
^^thx. Right now I have it hooked up and just not linked to my phone/bluetooth. On a side note I'd like to upgrade the maps/software but saw the disc is $150 from Navteq and I think that's ridiculous. Are these tied to a VIN or can I get one another way (i.e. find a used disc somewhere).
I just did mine, they are VIN locked. They require a code that you get when you buy it and is tied to the VIN.
07-15-2014 08:32 AM
1quick1 ^^thx. Right now I have it hooked up and just not linked to my phone/bluetooth.

On a side note I'd like to upgrade the maps/software but saw the disc is $150 from Navteq and I think that's ridiculous.

Are these tied to a VIN or can I get one another way (i.e. find a used disc somewhere).
07-02-2014 10:24 PM
jwilson2598
Quote:
Originally Posted by 1quick1 View Post
On my previous Jeep I upgraded the 130res w/Sirius no connectivity to the 430n and it was complete plug n play. I just ordered a 730n RHR from a member here out of a 2012. It seems plug n play but I'm getting conflicting info. Can I replace the 130res w/satellite and connectivity. Plug n Play with a 730n out of a 2012.
I answered in the other thread, but Mopar makes a harness that will adapt your 130 mic and USB port to work with the 730. Not terribly expensive if I remember correctly.
07-02-2014 08:21 AM
1quick1
Quote:
Originally Posted by WaltA View Post
The 730N has connectivity (uconnect/Bluetooth) built-in. I would assume one would need to remove the external connectivity hardware that supports the 130 or 430N.
Thanks for the response. I think you're right.

I'm having a hard time finding out though if I just do a straight plug n play swap if everything will work normally with the exception of BT/phone. I'm okay with that until I order the adapter needed or just not even bother with it.
07-01-2014 07:24 PM
WaltA
Quote:
Originally Posted by 1quick1 View Post
On my previous Jeep I upgraded the 130res w/Sirius no connectivity to the 430n and it was complete plug n play.

I just ordered a 730n RHR from a member here out of a 2012. It seems plug n play but I'm getting conflicting info.

Can I replace the 130res w/satellite and connectivity. Plug n Play with a 730n out of a 2012.
The 730N has connectivity (uconnect/Bluetooth) built-in. I would assume one would need to remove the external connectivity hardware that supports the 130 or 430N.
07-01-2014 03:06 PM
1quick1 On my previous Jeep I upgraded the 130res w/Sirius no connectivity to the 430n and it was complete plug n play.

I just ordered a 730n RHR from a member here out of a 2012. It seems plug n play but I'm getting conflicting info.

Can I replace the 130res w/satellite and connectivity. Plug n Play with a 730n out of a 2012.
06-25-2014 05:51 AM
WaltA
Quote:
Originally Posted by VKScott View Post
Okay so the missus and I are fixing to buy a 2014 Rubicon with NAV. The main question is, how user friendly is the 730N? We like the idea of trail marking (bread crumbs) feature but balk at the price. Any suggestions?
I have the 730N, but if I had it to do over again, I would have went with the 430N. The reason is that the 430N uses Garmin for NAV, and with that, you have all this great wealth of knowledge and support all over the 'net. The 730N uses Harmon for NAV, which nobody has really ever heard of.

The split screen is nice, but if you have Connectivity Package, the NAV directions can be displayed on the EVIC, making that your second screen.
06-25-2014 12:46 AM
Todd Phooz
06-24-2014 11:38 PM
jwilson2598
Quote:
Originally Posted by VKScott View Post
Okay so the missus and I are fixing to buy a 2014 Rubicon with NAV. The main question is, how user friendly is the 730N? We like the idea of trail marking (bread crumbs) feature but balk at the price. Any suggestions?
Personally I find mine easy to use. A couple other nice features on the 730 are side by side radio and Nav as well as the ability to control Nav by voice. The latter is nice if you need to set directions while moving and don't have a unlock device like AllGig to Lockpick.
06-24-2014 11:30 PM
VKScott Okay so the missus and I are fixing to buy a 2014 Rubicon with NAV. The main question is, how user friendly is the 730N? We like the idea of trail marking (bread crumbs) feature but balk at the price. Any suggestions?
06-22-2014 06:48 AM
2012unlimruby17 That's funny you say that! I feel the same way. I wish I could use it more...but two lil ones don't allow me to right now! Has anyone ever seen marks like that inside the touch screen? It's odd.
06-22-2014 12:00 AM
AUskier
Quote:
Originally Posted by Tonyvasconi View Post
Did you solve your issue ... I also am having trouble with soft-keys on 6.5-inch touch screen for uconnect 730N/RHR. They do not respond to "touch" and/or they invoke without "touch", i.e. a radio preset with change the channel, or the Navigation system will ask for "press" to find map location, or OK button with turn on/off. Any DIY fix, like you I want to avoid going into the dealer and get upsold to a new radio. Thanks T---
It definitely seems worse when the radio is dusty. But still happens some even with a clean screen. I can also see imperfections (pealing?) in what looks like a screen coating in the places I push the onscreen buttons a lot.

I like having an in vehicle navigation solution, but I'm about done with this unit. I haven't taken it in because of a crazy busy schedule but I'll update here when I do to see what they say.
06-21-2014 08:31 PM
tomthbomb Good that your dealer is replacing your 730N.

With 4,700 miles on a 2012 it could be because your Jeep is molding from lack of use.

I just turned 62,000 on my 2012 and drive it every chance I get. I have two other vehicles so it is by choice, not necessity.

Going to buy a 2015 when they are available.
06-21-2014 06:21 PM
2012unlimruby17 Also, my jeep is garage kept year round and has only 4700 miles on it. my summer toy
06-21-2014 06:20 PM
2012unlimruby17 I have also been experiencing issues with my 730N for the past 12months. I own a 2012 JKUR, and my issue started with some freezing issues and the volume not working and problems with the soft keys. I also noticed what appeared to be a large spot, dead center of the screen. I thought It was just fingerprints at first but, it appears to be some sort of condensation in between the outer and inner layers of the touch screen display ( i will attempt to attach photos below) this " blotch " is only there for approximately 20-30 mins upon start up.. and fades away to nothing behind the Digital clock display as I drive. I have contacted my local dealer and they are going to replace it for me free of charge. check the pix out.. tell me what you guys think.http://www.wranglerforum.com/attachm...1&d=1403392696
06-20-2014 05:43 PM
Tonyvasconi
Same Experience

Quote:
Originally Posted by AUskier View Post
I've kept up with this thread, but I doubt I've read every post.... Anyway I was wondering if anyone has had a touchscreen malfunction. My touchscreen is "clicking" or "touching" buttons without being touched. It started happening very rarely a couple of months ago but has gotten progressively worse. Yesterday it was almost unusable.

Maybe I'm cleaning it wrong? I just use a damp microfiber cloth.

I guess I'm going to take it to the dealer but I wanted to see if anyone had any experience with this.
Did you solve your issue ... I also am having trouble with soft-keys on 6.5-inch touch screen for uconnect 730N/RHR. They do not respond to "touch" and/or they invoke without "touch", i.e. a radio preset with change the channel, or the Navigation system will ask for "press" to find map location, or OK button with turn on/off.
Any DIY fix, like you I want to avoid going into the dealer and get upsold to a new radio.

Thanks
T---
06-04-2014 04:49 PM
schirmyver
Quote:
Originally Posted by jwilson2598 View Post
I believe the 3 units have a unified software, aka there is software for all 3 units on the disc, and then once it determines which one you have, it loads the proper one.
The update I just downloaded is for RHR, RHW and RHP so I can confirm this.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC