Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Update on ticking Pentastar..new head...

Join Wrangler Forum Today


Thread: Update on ticking Pentastar..new head... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-17-2014 11:32 PM
Tseg Yup, after my left head replacement it sounded like a river behind the dash. I squeezed the big black radiator tube intake trying to push bubbles out... Also got some GO5 radiator fluid and added a couple inches directly in the radiator as it looked like it was low. Not sure if it was my efforts but the water sound at start-up went away.
12-17-2014 10:36 PM
Hudler Sloshing sound should go away. Mine did it a few times when it was new, but went away after the first week or so.
12-17-2014 08:31 PM
gecko4
Quote:
Originally Posted by 03 TJX View Post
Never mind - 10 years / 150k, but only on the left side cylinder head.
The left side seems to be the problem child anyway.
12-17-2014 10:40 AM
03 TJX Never mind - 10 years / 150k, but only on the left side cylinder head.
12-17-2014 10:01 AM
03 TJX
Quote:
Originally Posted by gecko4 View Post
With the announced extended warranty on this problem, you've got nothing to worry about. If it does happen, it'll be covered. Enjoy you jeep!
Can you fill us in on that or provide a link? Thanks.
12-16-2014 05:42 AM
gecko4
Quote:
Originally Posted by Burgie View Post
Just bought a 2012 with production in Sept 2011. Left head is 2671A and right head is 2671B. 47,XXX miles. No problems yet.....
With the announced extended warranty on this problem, you've got nothing to worry about. If it does happen, it'll be covered. Enjoy you jeep!
12-15-2014 12:43 PM
Burgie Just bought a 2012 with production in Sept 2011. Left head is 2671A and right head is 2671B. 47,XXX miles. No problems yet.....
10-31-2014 06:13 PM
monte417 Just wanted to throw out an update. Got the check engine light 2000 miles ago with 44k on the vehicle. Code was P0304 which is the #4 cylinder head misfire. Brought it to the dealer Tuesday night after work. The service manager calls me the next morning (nice kid) and said they couldn't work on the truck because there was that "cow pusher" in the way. He was referring to my stinger lol that cracked me up. I had to run to the dealer weds night after work to take my front bumper off or they would have charged me $400 to do it. No thanks lol. I get a call today that its ready so not to bad on time. Got to the dealer and started it up to hear the sloshing fluid sound behind the dash. ive read about this issue but wondering how many have you have gotten this noise after the head replacement and what did you do. Is it just air in the coolant system/heater core and will it work its way out naturally? Should I take it back to the dealer (really don't want to)? What did you all do? BTW here is what they did
invoice 2.jpg

invoice 1.jpg
10-29-2014 10:09 AM
ElectricJay
Quote:
Originally Posted by truthiness View Post
Just traded my 2012 in with 41.2k and no issues at the time.
Did you trade for another Jeep?
10-28-2014 09:24 PM
truthiness Just traded my 2012 in with 41.2k and no issues at the time.
10-28-2014 05:05 PM
monte417 Does anybody have the number they called to Chrysler for the rent a car. I remember seeing it someone posting a good number to call for that
10-27-2014 10:57 PM
JKWrangler2012 3 years in and this thread still lives! Unreal. Almost 38k. Nonissue thus far...
10-27-2014 05:15 PM
the rock99 I am at 50,000 on a 2012 no problems so far.
10-27-2014 04:36 PM
tomthbomb
Quote:
Originally Posted by monte417 View Post
I'm taking mine into the dealer tmrw. 45k and change. Got the light at 42k
Ok, you have the record now!

Btw, I am now at 70k and all is well.
10-27-2014 03:06 PM
Riccochet 37k on my '12 with no tick or CEL. My wife beats on it too. lol
10-27-2014 02:27 PM
monte417 I'm taking mine into the dealer tmrw. 45k and change. Got the light at 42k
10-27-2014 02:03 PM
tomthbomb
Quote:
Originally Posted by GrewGruxKing View Post
Just hit 36k on my '12 here. No tic or anything yet.
Mine was replaced at 44k. I haven't seen anyone have it replaced with higher mileage on this forum.
If you make it that far you may be home free.
10-25-2014 09:49 AM
GrewGruxKing Just hit 36k on my '12 here. No tic or anything yet.
10-25-2014 05:40 AM
snobnk 53000 on my 2012 also....no cel or tic here either....
10-25-2014 01:22 AM
Up Hill Bill
Quote:
Originally Posted by blondiemachine View Post
I was at the dealer today and they say it isn't supposed to go from drive to first gear while driving at that speed. it apparently should go from drive to 5th. at least that was what the service adviser thinks. Thanks for answering so quick. Guess I will let them check it out and find out for sure.
It's supposed to go to the next lower gear. If you're in top gear (5th) it sould downshift to 4th unless you hold the lever to the left. Each tap to the left will take you down one more gear. Each tap to the right, up one gear. It will not shift if the RPM range is not OK for the gear you are calling for.
10-24-2014 10:40 PM
SilverMiner 53K miles on my 2012, and still no ticking ... I will have to trade it in before I hit 100K if it doesn't break I think.
10-24-2014 08:34 PM
Tseg
Quote:
Originally Posted by gecko4 View Post
Yes, that's definitely a new head. Built on the 156th day of 2014. Thanks for the update. Notice any difference with the new head?
Its been driving smooth and quiet (other than when a heat shield gives a little clack at high rpms). I did my first oil change (had just bought this used a few months back and 1 month in the dealership for repairs) and put in its first Mobil 1 oil change. It definitely idles much smoother. With 25K miles on it now it really feels like a new Jeep.

No regrets about buying a '12 expecting to need some engine work for this problem. It would have been nicer if the episode was 3 days vs. 3 weeks but my memory is short, luckily. Its just a blast to drive.
10-24-2014 08:19 PM
gecko4 Yes, that's definitely a new head. Built on the 156th day of 2014. Thanks for the update. Notice any difference with the new head?
10-24-2014 08:12 PM
Tseg
Quote:
Originally Posted by gecko4 View Post
It's odd you have to wait so long. I wonder if the back order problem with the heads still exists. Thanks for the updates. Once it's done, check the julian date of the replacement head. It will be interesting to see whether Chrysler is, in fact, reworking the earlier castings to be put into service. There is a pic a couple of pages back on a recently replaced head with an early date code.(built in 2011) It was never confirmed when I questioned it though. (Could have possibly been a passenger side head)
Is this what you are asking for?

10-24-2014 07:24 PM
blondiemachine I was at the dealer today and they say it isn't supposed to go from drive to first gear while driving at that speed. it apparently should go from drive to 5th. at least that was what the service adviser thinks. Thanks for answering so quick. Guess I will let them check it out and find out for sure.
10-24-2014 12:40 PM
Up Hill Bill
Quote:
Originally Posted by blondiemachine View Post
This is a bit off topic, have been trying to figure out how to ask a question and start a new thread...any way, I have a 2012 Sahara 4 dr Automatic and when I manually use the shifter it drops. always to the 1st gear on a down shift. Example the wife accidentally bumped the shifter with her knee in drive and it went to first. Is this normal???
It's normal. The downshift side of the shifter is WAY too sensitive, at least on my 2012, and many others I've tested and heard about.

You will need to learn not to rest your hand on the shift knob, especially when going around corners. Just a little extra pressure on the knob toward the driver, and you find your engine winding out from an accidental downshift. The worst for me was holding onto the knob at a stop sign and looking hard around to my left, checking for oncoming traffic before starting out from the stop. I still do that once in a while.

You will get used to it. I do it very rarely now, after three years of learning.





And, to start a new thread, click the "New Thread" button at the top left of the forum page:

Attachment 1589025
10-24-2014 11:34 AM
blondiemachine This is a bit off topic, have been trying to figure out how to ask a question and start a new thread...any way, I havve a 2012 Sahara 4 dr Automatic and when I manually use the shifter it drops. always to the 1st gear on a down shift. Example the wife accidentally bumped the shifter with her knee in drive and it went to first. Is this normal???
10-15-2014 05:22 PM
MikeK46
Quote:
Originally Posted by demarpaint View Post
Short answer no, not while under warranty.
Is that because this is not a recall?

I remember receiving a letter from Chrysler about a recall (the transmission line, I believe), and it said that I have the option of getting it fixed somewhere else and submitting the receipt to Chrysler for reimbursement.
10-14-2014 05:10 AM
demarpaint
Quote:
Originally Posted by MikeK46 View Post
Is there any way we can take our Jeeps to our local Jeep shop for the new head, and submit the receipt to Chrysler for reimbursement? Taking it to Chrysler all but guarantees that the Jeep will come back with new problems, and that you'll become a regular in their service department.
Short answer no, not while under warranty.
10-13-2014 10:14 PM
MikeK46
Quote:
Originally Posted by demarpaint View Post
I feel exactly the same way as you. For a repair with the price sticker of swapping a head, hate the dealerships or not that's a bill I wouldn't be footing either.
Is there any way we can take our Jeeps to our local Jeep shop for the new head, and submit the receipt to Chrysler for reimbursement? Taking it to Chrysler all but guarantees that the Jeep will come back with new problems, and that you'll become a regular in their service department.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC