Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > water in my oil

Join Wrangler Forum Today


Thread: water in my oil Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-25-2012 07:41 PM
Jon70 When you change the PCV valve you may want to check the crankcase vent to the rear of the PCV.
02-25-2012 11:54 AM
Kahuner X2 what ItsSabby said!! Great idea!!

Take it one step further and pressure test the cooling system. If it holds without the needle moving at all, it eliminates a bad head gasket, cracked block etc.

Good luck;
Kahuner
02-25-2012 09:35 AM
ItsSabby Have you changed your PCV valve? It could be clogged and allowing moisture to build up in the crankcase.
02-24-2012 07:48 PM
harleyman33 no it doesnt overheat...it doesnt smoke like alot is in the cylinders or anything...there is just enough in the pan that it shows a little on the dipstick...when i pull dipstick it is the brown milky look along the edge of the stick.
02-22-2012 05:20 PM
kmanator And anti=freeze eats the babbet material off the main/rod/cam bearings...so...you might get your wish soon
02-22-2012 05:17 PM
Mr Mac Usually water in the oil is indicative of a head gasket gone bad. Does it overheat at all?
02-22-2012 05:16 PM
harleyman33
water in my oil

ok...I got a 91 2.5L...I started gettin a little lifter tap noise...so i checked the oil and had alot of rust on the dipstick...oil was fine..also around pcv valve was watery oil..had that oily water look...then today i checked the oil again and now the oil in the pan is startin to get that creamy look to it....it doesnt tick when i first start it...but when it reaches norma temps it starts...and its not consistant...its quiet then loud then quiet then real loud then stops for a bit..then starts again...what the hell is the prob...i cant stand noisy engines...almost wanna blow it up so i have excuse to rebuild it...any help would be nice and appreciated....and also air filter looks like engine puked oil ad little water into it....all over the top of the filter

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC