Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Possible Fuel pressure problem

Join Wrangler Forum Today


Thread: Possible Fuel pressure problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-23-2012 07:56 PM
panrachlv 02 sahara
02-23-2012 12:12 PM
Jerry Bransford What model year TJ do you have?
02-23-2012 11:42 AM
panrachlv after doing some more research just now.... thinking it's the fuel pressure regulator. Is this common? Something we can do at home?
02-23-2012 11:34 AM
panrachlv
Possible Fuel pressure problem

Going to try and make a long story short: Bought my jeep Sept 2011, dealership put a new fuel pump in it before we took her home because it was having start up issues, but the new fuel pump fixed that. 45 days later I was "t-boned", but luckily I saw it coming so I turned quickly to the right(going 5-7MPH) and the driver that hit me, directly hit the driver side rear tire knocking it completely off of the axle (snapping like a carrot). well... after insurance.. etc... she was repairable (but just the body was damaged). I was hit on the fuel side, and since getting her back, she hasn't been starting up right away every time again. (usually when shes cold only will she start on the first try). Although, sometimes when I back her down the driveway (cold), get her out into the street, and put her in drive from reverse, she stalls out. (automatic) I since changed where I was getting fuel, put injector cleaner in, and swapped the fuel relay and the horn relay (since they are no different), and still no change. I cycle the ignition 1 or 2 times and sometimes she starts up just fine doing that. I've taken it back to the insurance company and they said they can't find anything, and my next attempt is to take it back to the dealership, but they sold her "as is"..... any ideas as to what it could be possibly???? Thank you!!!! someone did mention that when I got hit, maybe a switch was knocked out of whack! ?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC