Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Fuel injector cleaner caused major problems. NEED HELP!!

Join Wrangler Forum Today


Thread: Fuel injector cleaner caused major problems. NEED HELP!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-14-2008 10:52 PM
jpdocdave
Quote:
Originally Posted by Tj Bunch View Post
Dw Does the 93 have a fuel filter? my 01 is in the tank but it sounds as though maybe broke up some crap in the tank or lines and now the filter or injectors may be clogged.
i agree, change fuel filter, easy to do. also try cleaning the throttle body. jeeps will start acting real goofy like that, especially when they won't idle right, i've seen them get towed in, and this fixes it. if you need help on how let me know, don't use too much chemical.
03-14-2008 10:16 PM
Tj Bunch Dw Does the 93 have a fuel filter? my 01 is in the tank but it sounds as though maybe broke up some crap in the tank or lines and now the filter or injectors may be clogged.
03-14-2008 09:38 PM
dwilliams59
Fuel injector cleaner caused major problems. NEED HELP!!

Hi all,
I have a 93 Wrangler YJ with 160,000 on the engine. She runs strong with no problems up till now. I put a bottle of fuel injector cleaner in a full tank of gas. Didn't have any problems before, just tired of seeing the cleaner on my shelf. Ran the tank out no problems. Well after a fill up now I am in trouble. While idling it just cuts off after a minute or so. It also cuts off when I let off the gas while driving. It also pops and sputters when quickly accellerating, hense it acts like it is out of gas all the time. What do I do? I need help big time!!!!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:47 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC