Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > My Jeep has a strange squeal while I drive

Join Wrangler Forum Today


Thread: My Jeep has a strange squeal while I drive Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-24-2012 09:03 PM
neverfastenough1 You sure it went back to 2wd?
02-24-2012 12:57 PM
Snowbum How loud is it, I had spring pop off rub in the rotors, scared the crap out of me but was an easy fix
10-26-2011 10:27 PM
heepiejeepie If only the problem were that easy to fix
10-26-2011 10:25 PM
Jiffydarren Stop picking up hitchhiking mice.
10-26-2011 10:20 PM
heepiejeepie
My Jeep has a strange squeal while I drive

I have a 2000 TJ, that I recently bought. I purchased it in a big hurry because it was a great deal and I didn't want to loose it! I bought it so fast that I forgot to test the four wheel drive, so two days ago I tried it. Four wheel high and low seemed to work great, but after trying out the four wheel drive it now makes an obnoxious squealing noise when I drive faster than about 10 or 15 miles an hour. I can't tell if the noise is coming from a specific side or just underneath. My first thought was that a U joint could have gone bad, but there is no pattern to the noise like there would be with a bad U joint as the wheels turn. It never did this until after I tried the four wheel drive, so I'm wondering if it could have something to do with the transfer case?? Does anyone have any ideas or suggestions as to what the problem could be?? Any help would be greatly appreciated!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC