Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Front end

Join Wrangler Forum Today


Thread: Front end Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-27-2012 09:34 PM
JeepYJBoy
Quote:
Originally Posted by Square_Eyes
Is it just when you turn the wheel while not moving or are you moving and turning? Dry pavement or dirt? spring under or over? Lift? Check your drag link and tie rod for play in the joints
It's when moving and turning on dirt all stock what do you mean by "play"
02-26-2012 12:24 AM
Square_Eyes Is it just when you turn the wheel while not moving or are you moving and turning? Dry pavement or dirt? spring under or over? Lift? Check your drag link and tie rod for play in the joints
02-26-2012 12:08 AM
kmanator wheel loose....bad u joints in propeller shaft.....bad ball joint....gravel in your hubcap...Techno music on your stereo.....your dog swallowed marbles...
02-25-2012 11:50 PM
JeepYJBoy
Quote:
Originally Posted by 4Jeepn
Are you on drive pavement? I will guess axle shaft u-joint.
Nope....just replaced them and all new yokes and pinion seals
02-25-2012 10:52 PM
4Jeepn Are you on drive pavement? I will guess axle shaft u-joint.
02-25-2012 06:49 PM
Jeep716 Have it checked. Could be a lot of things like u joints ,dirty actuator , slop on transfer case chain even worn mounts.
02-25-2012 04:54 PM
JeepYJBoy
Front end

I have a 1990 yj and all of sudden when I put it in 4 lo and turn it makes a loud clinking noise

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:47 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC