Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > oil on spark plug

Join Wrangler Forum Today


Thread: oil on spark plug Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-26-2012 06:44 PM
Wrangler06 was about to say valve cover gasket haha happened to my buddys truck last week, gasket solved the prob ;]
02-26-2012 06:38 PM
Brianmlove so i changed out the valve cover gasket today so we will see if it stops.
thanks guys
02-26-2012 02:41 PM
doclouie If it was just on the threads it probably leaked from the valve cover and isn't a concern. Valve cover gasket is an easy fix.
02-26-2012 12:30 PM
Brianmlove The oil was just on the threads and it has a little over 86k on the engine
02-26-2012 10:02 AM
jgorm If its just the threads if may have leaked out of the valve cover into the plug hole. If the electrode has oil on it, the rings or valve seals are bad.
02-26-2012 12:28 AM
wolfpack72 Was the oil only on the threads and not on the firing gap? How many miles are on the motor?
02-25-2012 11:54 PM
Brianmlove
oil on spark plug

I have an 05 TJ X w/ 4.0 6 cyl auto and 2" suspension lift on 32x11.5x15's. I had a misfire code pop so I was checking to make sure that each spark plug was properly gapped and the last one i took out had oil on the threads. I was talking to my buddy and he said it was looking towards and engine rebuild, but I was going to get your guys opinion.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC