Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Didn't know where else to turn.

Join Wrangler Forum Today


Thread: Didn't know where else to turn. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-27-2012 05:38 PM
neverfastenough1 You rechecked the compression of that cylinder?
02-27-2012 04:17 PM
abturboz Good catch, very valid point.
02-27-2012 04:13 PM
Vector6
Quote:
Originally Posted by abturboz View Post
few years back his brother drove it into a river, and got it stuck.

Water levels raised and carried the jeep a few miles up.

i cant help with the other issues but this one bugged me..

technically speaking dont you mean down? as in "down stream"... just sayin...
02-27-2012 03:57 PM
abturboz
Didn't know where else to turn.

I have searched high and low for help with this jeep, no results. I shall give as much background and information on this thing as I can to get the help required. Here goes.

I'm working on my buddies 97 Wrangler SE with the 2.5 5speed manual. A few years back his brother drove it into a river, and got it stuck. Water levels raised and carried the jeep a few miles up. As soon as they got it pulled out and towed home all the fluids were drained and there it sat for two years.

Fast forward to a few months ago, I get a call asking if I can help get it back on the road. I go over, and give him a list of things I would recommend replacing. We changed the fuel pump, full distributor, wires, plugs, put all new fluids in it, made sure it wasn't locked up, and tried to start it up. It didn't exactly do what we were hoping. Started digging around and found that the shaft on the oil pump that turns the distributor had broken one of the ears off so it was only turning the distributor every once in a while. Replaced the oil pump and tried again. Finally after fiddling with the ignition timing for a few minutes it fired up, but the engine shook violently and then stalled. Got a couple of codes on the CEL, O2 sensors and TPS. Changed both of those out and adjusted the throttle screw so it would idle. Drove it about a mile and a half from his dads house to his house and it wouldn't go over 35 mph, any time he shifted from second to third gear it would bog down and slow him down in a hurry. Since then, we checked compression, all of the cylinders had between 120 and 130 psi.... Except cylinder 3, which had 25psi. Pulled the valve cover off and found that when turning the engine by hand the rockers/valves for that cylinder were not moving. With some gentle tapping on the rockers we got the valves freed up and everything was good, or so we thought. Went to start it up and hear music coming from the engine, but it wouldn't even fire. Switched the plug wires on the distributor so that it was 180 out of time and it starts, but shakes like crazy and have to keep foot on the accelerator pedal to keep it running. It is now worse than when it had a dead cylinder. I've been asking everyone I know for opinions and trying everything I could possibly think of to get this thing running decent again with no luck. If anybody here has any ideas they would be appreciated. Over two thousand dollars have been thrown at this thing in new parts already and I'd hate to tell him to do a swap on it and throw all that money away.

Thank you in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:22 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC