Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Michigan Jeep Forum > Information please

Join Wrangler Forum Today


Thread: Information please Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-02-2012 01:20 PM
darkproximity might be a cracked flex plate.. they like to crack around the bolts that hold them to the crank.. and then they make noise..
03-02-2012 08:51 AM
smith54 The sound is coming from behind the motor.
03-01-2012 10:41 PM
darkproximity the timing chain is in the front.. the transmission is behind the block theres no way the timing chain would be hitting the tranny pan.. it might be the tensioner has gone out and needs replaced and the chain is slapping against the timing chain cover.. its a time consuming job and you need some special tools to replace the chain.. is the noise coming from in front of the motor or behind?
03-01-2012 10:26 PM
smith54
Information please

I am looking at buying a 1989 wrangler yj 2.5 4 cyl. have a question on the timing chain. It makes a clicking noise. Seller says it hits against the tranny pan making the clicking noise, but he says it will run and drive ok with it. Is this a serious problem or not?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC