Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > 97 tj fuel pump

Join Wrangler Forum Today


Thread: 97 tj fuel pump Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-02-2012 07:30 PM
Jerry Bransford If you are not getting power to the pump itself, it's not the fuel pump. The ECM (engine computer) only sends power to the relay if it is happy with everything it checks like from the various sensors.

Do this... put your ear next to the fuel pump and then have an assistant turn the ignition switch to the On (not Start) position. If the wiring, relays, and fuel pump is ok, you will hear the fuel pump turn on for 1-2 seconds and then it will shut off again. If that happens, the wiring, relays, and fuel pump is ok and the problem is likely to be more sensor-related. Like perhaps the Crankshaft Position sensor mounted next to the flywheel up high on the driver's side. If the CPS isn't working as it should, the ECM will not power the fuel pump.
03-02-2012 07:01 PM
Rocky Bar
Fuel Pump Power

You might pull off the left rear wheel, and check the wiring jack up by the frame for power when key is in the run position.
03-02-2012 06:44 PM
rc51racer0023
97 tj fuel pump

I have a 97 TJ and I am having issues with the fuel pump. I am not getting power to the pump. I have checked the relay and it is fine and I also have power to the relay and fuse block. I am lost and not sure were to look any help would be great.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC