Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In > my 03 wrangler

Join Wrangler Forum Today


Thread: my 03 wrangler Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-05-2012 05:43 AM
Frenz It's been my experience that it's cheaper easier in the long run to buy a used motor.. www.car-parts.com
03-05-2012 05:31 AM
Barrie Welcome to the asylum.
03-05-2012 05:29 AM
JDsDream Welcome to the Forum

Try posting your question in the TJ section of the Forum for more views and responses.
03-05-2012 05:26 AM
shell Welcome!
03-05-2012 04:44 AM
blkrubi88 Welcome!
03-05-2012 03:14 AM
MrSig Welcome and enjoy the forum!
03-04-2012 10:42 PM
SilverSport Welcome Aboard!
03-04-2012 09:39 PM
Frenz Welcome to the WF
03-04-2012 09:32 PM
jerrylee33
my 03 wrangler

Hello, my name is jerry i am new to this site. I just recently aquired a 2003 jeep wrangler with a 2.4. I live in iowa, and flew to georgia to pick this jeep up. I had really good luck driving the jeep back to iowa, that is until i got about 125 miles from home. I was driving the interstate, and alll of the sudden it died. I got it pulled over to the shoulder and tried to start it. When i tried it was acting like it didn't have any spark, i knew right away that the timing belt broke. So i had it towed home, the next day i called a jeep dealership about it. Little did i know this motor is known as a interfearance motor and more than likely i bent valves. So i have a question for you fellow jeep 2.4 owners . Have any of you had this issue, and if so do you also have to replace the water pump. I have got a replacement head. And how hard is it to change the head. I would appreciate any information and guidance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:14 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC