Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In > Squeak - stops when gently apply brake?

Join Wrangler Forum Today


Thread: Squeak - stops when gently apply brake? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-02-2012 02:33 PM
JerryOnly
Quote:
Originally Posted by Irish Jeeper
The noise is from the front - a few revolutions of the front wheels until they seem to warm up and I gain speed.
Mine comes from the rear it's like a slow squeaky hamster wheel until it "heats up" and goes away. Any fixes yet?
03-13-2012 05:54 PM
Irish Jeeper The noise is from the front - a few revolutions of the front wheels until they seem to warm up and I gain speed.
03-09-2012 09:59 PM
JDsDream Welcome to the Forum
03-08-2012 10:41 PM
Destin to Dream Welcome, could be pad indicators.
03-08-2012 10:10 PM
GoldenSahara00 Hey Irish, I actually have had this noise pop up again in the past week. I had it a long time ago and fixed it (though I don't seem to remember how???) but, I would start with your pads as mentioned, thats the most likely place. Is the noise front or rear?
03-08-2012 09:52 PM
jsmithtx Check your pads.
03-08-2012 04:44 PM
Irish Jeeper Thanks all!
03-08-2012 04:19 AM
MrSig Welcome and enjoy the forum!
Check you pads might have to be changed.
03-08-2012 04:16 AM
blkrubi88 Welcome!
03-08-2012 12:31 AM
Te0
Quote:
Originally Posted by dabolt55
Welcome, maybe brake pad indicators??
Correct. If it stops when you press on brakes it should be brake pads need to be Replaced..
03-07-2012 11:33 PM
SilverSport Welcome Aboard!
03-07-2012 05:32 PM
wedu22 Welcome to the WF!
03-07-2012 05:27 PM
dabolt55 Welcome, maybe brake pad indicators??
03-07-2012 05:23 PM
kbwwolf Post in this section and you'll get some answers: TJ Jeep Wrangler Forum

And welcome to WF!
03-07-2012 03:43 PM
Irish Jeeper
Squeak - stops when gently apply brake?

Greetings!
Had my 03 TJ a year and luv it. Since I bought it I noticed a loud squeak just when I start rolling -worse in cold weather. It lasts at minute or two in parking lot speed and I'm not overly concerned - its a jeep and noise is part of the deal.
Just want to see if anyone has ideas of what could be causing it. Seems to cease when I ease gently on the brake and its not there at all when I pick up speed. Any ideas thoughts welcome.

Also, apologies to Jeep wavers - was not sure of etiquette but now on board.
Cheers!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC