Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 1 out of 3 brake lights

Join Wrangler Forum Today


Thread: 1 out of 3 brake lights Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-11-2012 03:33 PM
konajeep Thanks it was the wiring plug under the dash. Corrosion
03-08-2012 11:51 PM
Dutch 95
Quote:
Originally Posted by Master4th View Post
The Tail Lights are ground through the housing to the body. There are 3 bolts that hold your tail lights on. Those are the grounding bolts as well.
If you are positive that the bulbs are not blown, I will second that^^^^^. Those mounting bolts are the ground for the lights and have to be clean!

You could also check/clean the connections in the wiring harness leading to the tail lights in each corner (looking up into each back corner from the underside). Disconnect, clean, add dielectric grease.

Because the center tail light works, I would doubt the break switch is the issue.
03-08-2012 07:57 PM
Master4th The Tail Lights are ground through the housing to the body. There are 3 bolts that hold your tail lights on. Those are the grounding bolts as well.

Maybe your brake switch is bad, its connected to the brake pedal. Play with it and see if you get any flickers.
03-08-2012 06:31 PM
konajeep
middle light

Why do i have the middle light working? Any ideas where to look for bad ground
03-08-2012 05:28 PM
Garyk You've probably got a loose or bad ground. If the light worked before you had it apart, then I would look at connections etc for corrosion...
03-08-2012 05:26 PM
konajeep
1 out of 3 brake lights

95 YJ I had all 3 brake lights working,[tail lights work] then drivers side went out. I checked and cleaned bulb and socket put it back and both sides quit. The only brake light working is the one over the spare tire. Tail lights still work. Any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:22 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC