Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Jeep Clutch Mystery. Need help

Join Wrangler Forum Today


Thread: Jeep Clutch Mystery. Need help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-16-2012 05:08 PM
TexasT Try some more searches here. I've seen that problem mentioned several times but can't remember the solution. My memory is going...but I do remember my senior discount at ihop!
03-16-2012 01:33 PM
freeskier
Quote:
Originally Posted by jeepjones View Post
Holy thread Hijack Batman! How about posting this question as your own and not hijacking the OP's?
The OP posted in December of last year and was never responded too, mmoscatelli brought the thread back to life.

If the interlock has been bypassed then it is not the clutch. There is something else going on.
03-16-2012 12:47 PM
mmoscatelli i figured it'd keep the clutter down ha
03-09-2012 12:58 PM
jeepjones
Quote:
Originally Posted by mmoscatelli View Post
so this is what's been going on with my scenario...

Specs:
2005 Rubicon Unlimited
2"RE Lift w\teraflex tummy tuck on 33x12.50R15.. TB spacer and flowmaster.


I'm new to jeeps, just converted from land rovers (thank god) and my jeep, (bought from Mt.Zion Offroad in Dover PA, 77XXX miles) is my first manual vehicle. that said, I'm actually pretty good at using a clutch given my experience riding quads, dirtbikes and occasionally having to steal my buddies ride to grab a pack of smokes or something.. (so I'm not worried that it was my newb shifting at all.)

After about two weeks of buying my rig I realized that something just wasn't right, and it wasn't just the temp variations given this crazy weather we've been having in the northeast.. upshift from 1st to 3rd, mostly 3rd to 4th was "choppy" and felt like it grinded 3-5 teeth per shift without any noticable "grinding" sound (I just had the doors and sunrider mostly topless today).

After some research here and elsewhere I decided that my tranny fluid probably needed changing and a little bit of lucas. (although I'm not sure how it does with the NSG370 and all.. any thoughts on that? searching's proven inconclusive and I tend to lucas everything I can)

This morning I was warming the engine up as I always do out of habit from owning my Disco and I noticed a rattling sound sort of like when you hear a jap 4 banger's exhaust manifold heatsink come loose, and something just didn't "feel" right about the sound.. so, I pushed in the clutch a little bit and the sound definitely responded proportionally to the amount of clutch depression.. so I figured what the hell, and didn't think *that* much of it.. so whatever, went out did some errands, and on my last stop I literally shut the engine for 5 mins, got back in, turned the key and nothing. Did the key dance, no faults to be found. Checked the fuses, they were all good to go.. grounded the CPPS, nothing. Did the clutch override fuse trick, nothing. So...

I jumped the starter straight from the battery, no response. Autozone, 15 minutes and a new starter and relay. Installed both, still nothing. Jumped the starter again and but it was just spinning, the solenoid engaged (I think, well 98.4% sure)...... no idea what to do now in DIY terms, and thank god it's still under a 3k warranty from Mt. Zion...

Any thoughts?


\\I apologize for the lengthy explaination, I just figure it's better to write like i'm talking to other people, instead of a faceless cloud of knowledge
Holy thread Hijack Batman! How about posting this question as your own and not hijacking the OP's?
03-09-2012 12:49 PM
I-Want-A-Jeep Bump.. Where's Jerry?!?
03-08-2012 12:20 AM
mmoscatelli so this is what's been going on with my scenario...

Specs:
2005 Rubicon Unlimited
2"RE Lift w\teraflex tummy tuck on 33x12.50R15.. TB spacer and flowmaster.


I'm new to jeeps, just converted from land rovers (thank god) and my jeep, (bought from Mt.Zion Offroad in Dover PA, 77XXX miles) is my first manual vehicle. that said, I'm actually pretty good at using a clutch given my experience riding quads, dirtbikes and occasionally having to steal my buddies ride to grab a pack of smokes or something.. (so I'm not worried that it was my newb shifting at all.)

After about two weeks of buying my rig I realized that something just wasn't right, and it wasn't just the temp variations given this crazy weather we've been having in the northeast.. upshift from 1st to 3rd, mostly 3rd to 4th was "choppy" and felt like it grinded 3-5 teeth per shift without any noticable "grinding" sound (I just had the doors and sunrider mostly topless today).

After some research here and elsewhere I decided that my tranny fluid probably needed changing and a little bit of lucas. (although I'm not sure how it does with the NSG370 and all.. any thoughts on that? searching's proven inconclusive and I tend to lucas everything I can)

This morning I was warming the engine up as I always do out of habit from owning my Disco and I noticed a rattling sound sort of like when you hear a jap 4 banger's exhaust manifold heatsink come loose, and something just didn't "feel" right about the sound.. so, I pushed in the clutch a little bit and the sound definitely responded proportionally to the amount of clutch depression.. so I figured what the hell, and didn't think *that* much of it.. so whatever, went out did some errands, and on my last stop I literally shut the engine for 5 mins, got back in, turned the key and nothing. Did the key dance, no faults to be found. Checked the fuses, they were all good to go.. grounded the CPPS, nothing. Did the clutch override fuse trick, nothing. So...

I jumped the starter straight from the battery, no response. Autozone, 15 minutes and a new starter and relay. Installed both, still nothing. Jumped the starter again and but it was just spinning, the solenoid engaged (I think, well 98.4% sure)...... no idea what to do now in DIY terms, and thank god it's still under a 3k warranty from Mt. Zion...

Any thoughts?


\\I apologize for the lengthy explaination, I just figure it's better to write like i'm talking to other people, instead of a faceless cloud of knowledge
03-07-2012 07:36 PM
I-Want-A-Jeep Will be interested to see where this one goes. I would figure if the override was activated then the clutch wouldn't have any bearing on whether the Jeep would start or not.
03-07-2012 07:20 PM
mmoscatelli bump.. similar problem happened\is happening to me now. HELP
02-12-2011 03:02 PM
madjack2060
Jeep Clutch Mystery. Need help

Okay, here's the problem that has had me stumped for months. Sometimes my jeep won't start when I turn the key. All the electrical comes on. To get it to turn over I have to repeatedly slam the clutch pedal to the floor as hard as I can while turning the key. It eventually turns over. Before you answer, I already overrode the clutch pedal fail safe. To be clear, that means that under normal circumstances, I can start my 2000 TJ without pressing the clutch in at all. But when this problem occurs, I still have to smash my clutch pedal to the floor. I disabled the clutch override by inserting a fuse into the appropriate override slot in the fuse box. Anyone have any suggestions on what I could try next, or if there is another clutch switch I don't know about?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC