Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > new vibration and rear wheel squeal

Join Wrangler Forum Today


Thread: new vibration and rear wheel squeal Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-16-2012 11:29 PM
trailerking *update*

the squeal was caused by the centering ball in the cardan joint on the front driveshaft, the so called 'angry sparrows".

the vibration was caused by one of the u-joints on the rear driveshaft. replaced both u-joints on the rear driveshaft at work today and my jeep is completely vibration free now. i plan on tackling the front driveshaft this weekend at home. bought all 5 u-joints and centering ball rebuild kit at my local parts house for right around $100 bucks.

i posted this update not because anyone gives a crap. i posted because i'm a drunken, vodka swilling buffoon who saved a couple hundred $$ fixing my own jeep thanks to this fine forum. cheers
03-09-2012 10:58 AM
trailerking
new vibration and rear wheel squeal

i have a 1999 sahara 4.0/5spd w/a 3" lift and 33's. yesterday on the way home from work the jeep developed a moderate vibration from around 25mph up. i got home and did a visual check of the suspension and driveline and all seemed ok besides a couple of the seals that hold grease in the rear u joint were broken or missing. when driving slowly through my neighborhood a little later i also noticed that the rear p/s wheel has started to squeal when making a left turn but stops when going straight.

anyone have any ideas? could the two problems be related? i've read tons of posts on here but i could'nt fing anything similar this.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC