Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Installed new mulitfunction switch and now my blinkers and hazard light dont work.

Join Wrangler Forum Today


Thread: Installed new mulitfunction switch and now my blinkers and hazard light dont work. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-04-2008 05:48 PM
jeeperman If the blinkers and flashers don't work, it sounds like something is grounded that shouldn't be. (At least that was the case when I did my LED lighting all around). Check all of your wiring to make sure nothing is shorting out. This could go along with your battery issues. Good luck.
04-04-2008 05:34 PM
Triple88a maybe u puled the blinkers switch wires off or soemthing?

sorry cant be much help on that as my light switch is not on the steering column.
04-04-2008 05:19 PM
jpdocdave ya, just look in owners manual for fuses, relays, and flasher related to the turn signal system. start w/ the basics is my first step.
04-04-2008 04:33 PM
tkoTJ Hi jp

i've checked the fuses in the glovebox for the blinkers and they look fine. By relays you are referring to the set next to the battery'?
04-04-2008 04:14 PM
jpdocdave i just read your other thread about your battery probs, and not getting jeep to start even with a jump, w/ that in mind check fuses, flashers, and relays before you dig any further. sometimes trying to jump battery, that weak can blow fuses and so on.
04-04-2008 02:40 PM
tkoTJ
Installed new mulitfunction switch and now my blinkers and hazard light dont work.

hi Jeepers,

i was hoping someone ran into this issue. i just replaced the mulitfunction switch on my 01 Wrangler TJ and fog and headlights work fine...however now my blinkers and hazard light do not work...do i need another relay switch separate from the multifunction switch?

when i swapped it out it was a 1:1 plug, unless i'm missing something here.

any help is appreciated. thanks in advance!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC