Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > my 99 tj keeps cutting out

Join Wrangler Forum Today


Thread: my 99 tj keeps cutting out Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-23-2012 07:39 AM
crallscars
Quote:
Originally Posted by magic21 View Post
looks like the Distributor swtich plate took care of it!! runs good now. THANKS

Glad it worked out for you.
03-22-2012 07:32 AM
97flexy so did the OP have a CK engine light on? I'm have'n all sorts of idle and accelerating issues with my heep... it not even fun to drive anymore... It get vapor lock when its warm and I shut it down for a few mins than start back up to drive it. I'l start drive'n it and it will kill it self if I just keep give'n it gas but if I throw it in neutral and rev the crap outta it, it seems to blow that crap past and not do that one issue any more, any yal have that problem? my jeep is a 2.5L, 5speed
03-22-2012 07:04 AM
2002TJ Back in '77 I bought a brand new Dodge van with 318 engine and auto tranny.....10 miles from dealership the distributor shaft ate it's way upwards thru the cap..really, the whole shaft forced it's way up and destroyed the cap and rotor and yanked plug wires off.

I coasted into a parking spot in Kittery Maine right in front of a parts store. They sold my poor ass a new distributor cap and rotor and wires and lent me tools and timing light to install it all....got back to dealer just before closing time and they blew me off cause i was young and stupid and they didn't fix it under warranty.

This Jeep is the first Chrysler product I've owned since....No complaints
03-22-2012 04:58 AM
magic21 looks like the Distributor swtich plate took care of it!! runs good now. THANKS
03-20-2012 06:50 AM
magic21 thank you, I will try that today. I will let you know!
03-19-2012 08:23 AM
crallscars had a simular problem, and was directed to replacing the "Distributor Plate" It's inside the distributor where the points use to be, very easy to replace, and a comon problem.
03-18-2012 03:56 PM
rigchaser Mine was the Crank Positioning sensor. No engine code? Located below your brake pedal where block and bell housing meet. Easy to replace. If thats the issue.
03-18-2012 05:08 AM
magic21
my 99 tj keeps cutting out

when jeep shifts it seems to cut out! if I down shift and bring up the RPMs it will clean it's self out and run find

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC