Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > wrangler clutch problem

Join Wrangler Forum Today


Thread: wrangler clutch problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-19-2012 10:51 PM
Kevbz what year, tranny you got?

external slaves are all one unit from master to slave, (you can find separate master's and slaves, but are not easy to swap)

buy the whole assembly, already pre-bled with fluid in them (they are that much of a PITA to bleed they come with fluid in them from the supplier)

short of the cap being bad there should be a telltale sign of fluid somewhere on the master, the line or the slave.

If it is low on fluid and just sucked some air into it and not leaking...take the slave off the tranny and with a helper up top watching the fill res., pump the piston in/out until no bubbles are present up top, filling if necessary. Don't use the clutch petal, it wont work that way...you cant bleed these top down, you have to use the slave to push air up and suck fluid down. Hold it in a way that the line cant trap air either..it has some 180's and preformed curves in it.

first and reverse sounds like syncros though...you'd experience a bad slave in every gear...although a bit easier since you could be floating, or "power shifting" those gears at speed
03-19-2012 07:30 PM
NHWRANGLER so bleed the line and seee what happens? prob replace slave or master.
03-19-2012 09:35 AM
QADaemon Sounds like you have a master or slave cylinder leaking air into the line somehow.
03-18-2012 08:10 PM
NHWRANGLER
wrangler clutch problem

my jeep has been hard to get into first for a while. we got a bunch of snow and i let it sit. now my clutch goes all the way down but i cane get it into gear. if i pump it it goes into first and reverse.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC