Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Take a look at this

Join Wrangler Forum Today


Thread: Take a look at this Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-26-2012 01:36 PM
GoldenSahara00
Quote:
Originally Posted by Muddeprived
Just make sure everything's torqued down properly. Heard stories of ring gear bolts coming loose.
I torqued the crap out of them. 85 ft/lbs with a torque wrench. I will prob be reinstalling within a year or two into an hp 30.
03-26-2012 07:35 AM
Muddeprived Just make sure everything's torqued down properly. Heard stories of ring gear bolts coming loose.
03-25-2012 08:24 PM
GoldenSahara00
Quote:
Originally Posted by Tdog02
Don't grind the ring, bad things will happen. What problems you having?
I broke my 1/2 drive on the hub bolts. It was my dads old husky. The gears must have went. That was the big issue. Also getting the roll pin out was hard because I didn't find my punch til after I tried everything else. Otherwise it wasn't too bad. Took me longer than I wanted but I had a buddy stop by and my dad stop in towards the end. Took about 5 workings hours I would say mostly because I hadnt don't it before and I was taking my time. I also had to mount my big bench vise because it had been sitting on the floor. I have a very bad back so some things were tougher for me.
03-25-2012 05:36 PM
Tdog02 Don't grind the ring, bad things will happen. What problems you having?
03-25-2012 03:19 PM
BLK00TJ I think I remember reading that you can grind off a section of teeth in the ring to keep from removing the carrier. To me that sounds too scary.
03-25-2012 03:03 PM
GoldenSahara00 Yeah it definitely needs pulled. I'm in the middle of it, and lucky me ha a few issues already.
03-25-2012 11:22 AM
BLK00TJ
Quote:
Originally Posted by Racer38 View Post
I didnt think you had to pull the carrier for this install ??
I believe it only needs to be pulled for the front axle.
03-25-2012 09:59 AM
Racer38 I didnt think you had to pull the carrier for this install ??
03-25-2012 08:39 AM
GoldenSahara00 Sweet. I just want to make sure I put the straps and the ring back on the right place. Otherwise it's just pull it out, drop them in, put it back in. Lol. Time to do this thing.
03-25-2012 08:19 AM
Tdog02 About 4 hours total for instal. I thought there would be more problems but it was stupid simple. My biggest concern was what it looked like when I put the cross pin in. (see pic above) my carrier came out pretty easy, just turn the drive shaft while pulling and it pops out. Honestly I was worried for nothing, it was too easy!
03-24-2012 09:40 PM
GoldenSahara00
Quote:
Originally Posted by Tdog02
That's how it's supposed to look, all works as its supposed to.
Sweet. I think I am gona start mine in the am. How long did it take you and any hangups ?
03-24-2012 09:08 PM
Tdog02 That's how it's supposed to look, all works as its supposed to.
03-24-2012 02:17 PM
Tdog02 Thanks
03-24-2012 12:52 PM
GoldenSahara00
Quote:
Originally Posted by Tdog02
I'm putting a spartan in the front, this is what it looks like... Is this right?
I think, I'm actually going to start my Aussie this evening I think. Ibuildembig just did a write up of an install of the spartan like a week ago. See if you can find it.
03-24-2012 12:41 PM
Tdog02
Take a look at this

I'm putting a spartan in the front, this is what it looks like... Is this right?


Attachment 107739

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC