Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum > Clutch issues

Join Wrangler Forum Today


Thread: Clutch issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-05-2012 09:03 AM
lynn Replace the entire linkage. Quadratec has a kit
Rod Links CMP7560 - Rod Links Clutch Linkage for 76-86 Jeep® CJ - Quadratec

They also have a kit to use with body-lifted rigs
Rod Links CMP7560-1 - Rod Links Clutch Linkage for 76-86 Jeep® CJ with 1-3" of Body Lift - Quadratec

Lots of info out on the web on CJ forums, search for "CJ heim joint clutch linkage"
03-25-2012 10:18 PM
sean112280 No cant blame ya. I would try to. Lol
03-25-2012 09:54 PM
Rusty Knutt Can ya blame a guy for trying?
03-25-2012 09:02 PM
sean112280 I think I temp fixed it until I upgrade to hydraulic clutch. I took off the "ball" and added washers to move it over. So it seems to be working for now. I'll have to pass on giving it up Rusty...lol. Good try though
03-25-2012 08:47 PM
Rusty Knutt Oh and it might just be the retainer clip in the end of the rod is wore out....replace it. < hope its this one, its the cheapest option.
03-25-2012 08:43 PM
Rusty Knutt OK, I have given this some thought.....

Number 1....Are you running a bodylift? If so perhaps you need to lengthen one rod and shorten the other.

Number 2....Are you body isolators just slam wore out? If so maybe you need to replace all of them.

Number 3....Go hydraulic?

And if these are not to your liking...just give it away, to me. I think I could deal with it.
03-24-2012 10:07 PM
sean112280 Anybody have any ideas?
03-24-2012 05:32 PM
sean112280
Clutch issues

Ok so here is my problem. My clutch keep giving out on me. I've come to the conclusion that is bc the shaft is right on the steering shaft and when I hit a bump it comes off. Now my question is how do I go about fixing this problem? Is there a longer "ball" that I can put on to make the shaft connect further over or what? Any suggestions will help. Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC