Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Check Engine and ETC Light

Join Wrangler Forum Today


Thread: Check Engine and ETC Light Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-01-2012 03:26 PM
Blackened
Quote:
Originally Posted by tcass View Post
k...help me out here....PCM...... ?-Control-Module? Gonna have to see what they say about mine.

cass

Powertrain Control Module. Let me know if they say the same thing is wrong with yours.
04-01-2012 09:35 AM
tcass k...help me out here....PCM...... ?-Control-Module? Gonna have to see what they say about mine.

cass
03-28-2012 06:23 PM
Blackened Well I got mine back today after the PCM was replaced and so far so good. Seems to be running fine, crossing my fingers that it stays that way.
03-28-2012 06:14 AM
willee51
Quote:
Originally Posted by Blackened View Post
Oh ok. Well hopefully it is the cause with mine and is fixed after they replace it. Good luck with yours, I hope what they did is more than a patch.
NOPE! A "patch" is exactly what the fix is

They split a section of rubber-hose and used wire-ties to cover the metal end of a air-cond hose, that they said was causing the grounding problem with an electrical-line

??????????????? My opinion, it's all a cover-up, but I have all documentation and have the life-time warranty!

The next failure, #4, I am gettig a Laywer and sueing under the VA Lemon Law!

All total it was in the shop about 3-weeks
03-27-2012 04:27 PM
Blackened
Quote:
Originally Posted by willee51 View Post
They said that they determined the PCM was not the cause

Oh ok. Well hopefully it is the cause with mine and is fixed after they replace it. Good luck with yours, I hope what they did is more than a patch.
03-27-2012 03:34 PM
willee51
Quote:
Originally Posted by Blackened View Post
Wait so did they replace your PCM?
They said that they determined the PCM was not the cause
03-27-2012 02:05 PM
Blackened Got a call today and they are saying it is the PCM. They are trying to track one down and hopefully I will have it back by tomorrow.
03-26-2012 08:34 PM
Blackened
Quote:
Originally Posted by willee51 View Post
-------------------
Engine failed 3X (once during the Dealer test-drive after fix #2)! The fix was, well, a real "bandaid-fix"! Still running for now!

I kept blowing "coil paks" , all at hi-way speed

When deep in the Blue Ridge Mtns, many miles from any paved-road, I am still concerned about failure #4, due to the "bandaid-fix"

Wait so did they replace your PCM?
03-26-2012 06:16 PM
willee51
Yep!

Quote:
Originally Posted by kjeeper10 View Post
Member Willie I believe has his 12 back and forth to the dealer. PCM was replaced I think. Turned out to be an electrical short.
Just something to point out
-------------------
Engine failed 3X (once during the Dealer test-drive after fix #2)! The fix was, well, a real "bandaid-fix"! Still running for now!

I kept blowing "coil paks" , all at hi-way speed

When deep in the Blue Ridge Mtns, many miles from any paved-road, I am still concerned about failure #4, due to the "bandaid-fix"
03-26-2012 05:50 PM
kjeeper10
Quote:
Originally Posted by Blackened
Got it in to the dealer today. They think it may need a new PCM but will know more info tomorrow.
Member Willie I believe has his 12 back and forth to the dealer. PCM was replaced I think. Turned out to be an electrical short.
Just something to point out
03-26-2012 05:37 PM
Blackened Got it in to the dealer today. They think it may need a new PCM but will know more info tomorrow.
03-26-2012 02:58 PM
Revyjku08 Looks like dealer time! May have some faulty spark plug wires or maybe a sensor???
03-26-2012 12:11 PM
Blackened
Quote:
Originally Posted by kjeeper10 View Post
good luck


Thanks I have a feeling my JK will need it. I will keep you all updated on what the dealer says.
03-26-2012 11:57 AM
kjeeper10 good luck
03-26-2012 11:54 AM
Blackened Really no one has gotten these codes on a 12 yet? I feel special now.. and not in a good way.
03-25-2012 06:00 PM
Blackened
Check Engine and ETC Light

So my check engine light came on today and about a half mile later so did the electronic throttle control light. Only 2,000 miles on it and I barely got it home because it kept wanting to stall out at lower RPM's. Here is the list of 7 codes I pulled..

P0306 Cylinder 6 Misfire
P0201 Injector CKT open cylinder 1
P0202 Injector CKT open cylinder 2
P0203 Injector CKT open cylinder 3
P0204 Injector CKT open cylinder 4
P0205 Injector CKT open cylinder 5
P0206 Injector CKT open cylinder 6


Does anyone know if this is related to the ticking Penastar thread? I haven't been keeping up with it.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC