Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 2012 JK Soft Top Question

Join Wrangler Forum Today


Thread: 2012 JK Soft Top Question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-27-2012 05:23 AM
radioscooter Sorry, I've got the 4 door. There are 4 shorter bolts and 2 longer ones.
03-26-2012 08:39 PM
IowaRaider
Quote:
Originally Posted by radioscooter View Post
Yeah, I had the same problem, or at least it sounds the same, when I did mine this week. They just ended up actually not being threaded right. Well, first I had the 2 different length screws switched, but after swapping, I experienced the play you're talking about, and it ended up being that the rollbar fabric was blocking some part of the screw.
Different length screws, mine are the same length?
03-25-2012 11:52 AM
woodyaks Figured it out. I pulled it all apart and noticed that on the roll bar around the front hole was some thick clear tape of some sort. There was none of this tape around the rear hole. So I took some packing tape and layered it up 3 or 4 times on the rear roll bar hole and now it's nice and snug.

This also fixed my 2nd problem!

Thanks for the help fellas!
03-24-2012 10:48 PM
radioscooter Yeah, I had the same problem, or at least it sounds the same, when I did mine this week. They just ended up actually not being threaded right. Well, first I had the 2 different length screws switched, but after swapping, I experienced the play you're talking about, and it ended up being that the rollbar fabric was blocking some part of the screw.
03-24-2012 09:44 PM
IowaRaider
Quote:
Originally Posted by cavsvet74 View Post
I would double check to make sure your door surrounds (plastic runner) is installed properly.
It doesn't sound like it is. The screws should both be tight. Check that the roll bar padding isn't in the way and the door surround is seated properly and lines up with thw screw holes.
x2 on this, make sure the padding is out of the way. If it is, post a couple pictures maybe we can see the issue.
03-24-2012 06:51 PM
woodyaks I don't know. I removed it and re-installed it 3 times. There's not much to it. Just align things and bolt them down. Everything seems to align properly and fit. Its just those 2 rear screws don't secure things to the roll bar properly. The front ones are perfect.
03-24-2012 06:44 PM
jp2611
Quote:
Originally Posted by cavsvet74 View Post
I would double check to make sure your door surrounds (plastic runner) is installed properly.
x2 ---all the "hardware" on my '12 JK is pretty solid.
03-24-2012 06:42 PM
cavsvet74 I would double check to make sure your door surrounds (plastic runner) is installed properly.
It doesn't sound like it is. The screws should both be tight. Check that the roll bar padding isn't in the way and the door surround is seated properly and lines up with thw screw holes.
03-24-2012 06:32 PM
woodyaks
2012 JK Soft Top Question

I just removed the hardtop for the summer and got the soft top installed on my 12 JK for the 1st time. I got it on but with some wrestling, and it works, but I did run into 2 issues.

1st one is minor. I installed the plastic runners and cranked down the 2 screw dealies on each side. The front screw dealy tightens things down nicely. The rear one leaves a good amount of play so the runners wiggle a bit and even rattle when the top is down. I cranked the screw dealies all the way down till they bottom out and there is still some play. Is this normal? I was thinking I might figure out some shims to take the play out.

The 2nd issue is definitely more of a PITA and may be related to my 1st issue. With the top down I pull the top over the Jeep and I align the center knuckle so that it clicks into the plastic runners. I then pull the rear corners down to tighten the back of the top. As I pull the rear down the left knuckle ends up popping out of the runner. It takes about 4 or 5 tries playing around with the knuckle/runner connection to get it to stick. Any ideas why the knuckle won't stay locked in? Could it be because the runner has too much play in it? Is there a better technique?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:15 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC